Jump to content
TCH-Rob

The Bat! Remote Buffer Overflow Vulnerability

Recommended Posts

The Bat! is prone to a remote buffer-overflow vulnerability. This issue is due to a failure in the application to perform proper bounds checking on user-supplied data before storing it in a finite-sized buffer.

 

An attacker can exploit this issue to control program flow and execute arbitrary attacker-supplied code in the context of the victim user running the affected application.

Share this post


Link to post
Share on other sites

Not The Bat! too! Is nothing sacred?

 

Thanks for the head's up, Rob.

Share this post


Link to post
Share on other sites

Hey, I've heard of that program :)

 

Twice in one month, at this rate the free publicity should swell the user ranks to almost double what they had last year. I wonder if they are going IPO or trying to sell the program?

Share this post


Link to post
Share on other sites

No silly Thomas. I meant, when I was looking at me emails about security notices and comparing them with what we had posted in this part of the forums, I did not notice that it had already been covered. I am aware of the fact that I did post in the other thread now that it has been brought to my attention.

 

You better stop picking on me, I am mailing you something this weekend and if you are not careful I just might keep it for myself. :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...