Jump to content
tamda

Secure Webmail Access

Recommended Posts

Hi,

 

My websites are hosted by TCH and wondering if there is a way to redirect webmail access automatically to secure access.

 

What I am trying to do is, if I type "*****/webmail", I want it redirected to "https://www.****/webmail" (note the "s" at the end of "http").

 

I don't want to embed a script on the website to direct my users to SquirrelMail or Horde because they won't have access to "Change Password", "Forwarding Options", "Auto Responder", and "Aging" options. Unless they login the regular way which will be too much of a hassle.

 

 

Thanks for the help.

 

 

Dave

Share this post


Link to post
Share on other sites

Edit the .htaccess file manually after you set up the redirect to add the "s" and it should work.

 

The .htaccess file can be edited using File Manager in cPanel. It will be in the public_html folder.

Share this post


Link to post
Share on other sites

Hmmm

I tried but it looks like webmail can't be redirected

even with editing the .htacess file to add the s in https

 

I just have a link to web mail as above on my site

Share this post


Link to post
Share on other sites

Bruce,

 

I got the same result as Don. It just brought me to the regular (http://) webmail screen instead of the secured webmail (https://).

 

Did we do something wrong?

 

Thanks.

Share this post


Link to post
Share on other sites

I am sure its because webmail is a special folder,

thats why I ended up using a secure link on my site.

Share this post


Link to post
Share on other sites

I wasn't sure if it was possible or not. Without your own SSL cert it may not be.

Share this post


Link to post
Share on other sites

I'd like to revisit this topic, if I may.

 

I've been using Squirrel mail for some time now and have successfully done so with https://****/sqmail

 

I'd like to move to Roundcube, which I can only get to by using http://****/webmail and then wait for the redirect. Because of the special folder status causing the redirects to port 2095, I am not able to get a secure connection.

 

I need to be able to connect securely so I don't pass my username/password in the clear over the network.

 

What options are there?

 

Do I need to install my own version of Roundcube in my site for this?

 

Has anyone else successfully done so?

Share this post


Link to post
Share on other sites

You can get to it securely if you do this:

 

>https://your-domain.ext/webmail

 

When prompted to login, use your email address and password.

 

If that fails because of the shared SSL certificate do this:

 

>https://your-TCH-servername/webmail

 

Again, use your email address and password to login.

Share this post


Link to post
Share on other sites

Yeah, that works. I was hoping for a less "kludgy" way of doing it. With the webmail folder I have to select whether I'm behind a firewall that blocks 2096 or not. Then I have to wait for the auto-redirect.

 

Squirrelmail is setup to use https://domain/sqmail - it would be nice if you could also https://domain/roundcube or horde if you so chose.

Share this post


Link to post
Share on other sites
Squirrelmail is setup to use https://domain/sqmail

 

That particular installation of squirrelmail is a cpanel independent one that we maintained so that clients can access their email if the default port 2095/2096 is blocked. This will be discontinued shortly as cpanel now provides "proxy domains" which would port 2095,2096 to 80. This can be accessed via http://webmail.your-tch-domain.ext/

 

If this feature is not available on your server, kindly give us some time. It is being pushed gradually as and when servers are upgraded.

Share this post


Link to post
Share on other sites

That's good to know. Thanks. I just checked and it works for my domain.

 

Is there any way to set the default webmail app without having to wait for the auto-redirect?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...