Jump to content

Smf Problems After Move


tomowa
 Share

Recommended Posts

Greetings,

 

I sent my brother here to TCH. TCH techs moved the whole account from the previous webhost. All well so far, so it looks at first http://www.lowcountrymudrats.com.

 

Yet no one can make a post to the SMF forum. The message when posting is:

Database Error: Duplicate entry '0' for key 1

File: /home/******/public_html/forum/Sources/Post.php

Line: 1297

So I downloaded the database dump from the previous host, and using phpadmin, went to upload and inflate the dump file, and ened up with this:
SQL query:

CREATE TABLE `smf_attachments` (

 

`ID_ATTACH` int( 11 ) unsigned NOT NULL AUTO_INCREMENT ,

`ID_MSG` int( 10 ) unsigned NOT NULL default '0',

`ID_MEMBER` int( 10 ) unsigned NOT NULL default '0',

`filename` tinytext NOT NULL ,

`size` int( 10 ) unsigned NOT NULL default '0',

`downloads` mediumint( 8 ) unsigned NOT NULL default '0',

PRIMARY KEY ( `ID_ATTACH` ) ,

UNIQUE KEY `ID_MEMBER` ( `ID_MEMBER` , `ID_ATTACH` ) ,

KEY `ID_MSG` ( `ID_MSG` )

) ENGINE = MYISAM DEFAULT CHARSET = latin1

MySQL said:

 

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 11

 

The MySQL version at the previous host was MySQL 4.1.14-standard

Here at TCH server 110 it is MySQL 4.0.25-standard

 

I believe this is the problem. Can anyone shed any light on this, and if this is the problem, can/how it be rectified? I have been through the SMF to no avail......

 

Thanks for any thoughts,

 

Tom

Link to comment
Share on other sites

Thanks Bruce, I just got it going :) Now I can go to work!

 

This was it:

 

It was a MySQL database issue, the 'old' server version of MySQL was MySQL 4.1.14-standard

The 'new' server MySQL version was MySQL 4.0.25-standard, an older version.

Had to remove references to 'DEFAULT CHARSET=latin1' and 'COLLATE utf8_unicode_ci' in the MySQL dump, then upload the dump again. All works now ;)

 

I actually ended up at WordPress forum, to find this solution http://wordpress.org/support/topic/61160.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...