Jump to content

Chmod Appends "*" To File Name Display


stapel
 Share

Recommended Posts

I've been uploading files today using CuteFTP. Some of them need their permissions changed. When I used CHMOD in CuteFTP to change a PHP script from 644 to 744, the permission change went through, but the file then displayed (on the server side) as "filename.php*". That is, CuteFTP had appended an asterisk to the end of the file name.

 

Sort of.

 

If I then tried to do anything with that file, CuteFTP told me that it didn't actually exist. For instance, if I highlighted (select) the file and tried to "Rename" it, CuteFTP would tell me that "filename.php* doesn't exist".

 

I deleted the file through the "File Manager" in cPanel, re-uploaded through CuteFTP, and changed the permissions in cPanel. When I "refreshed" the server-side file listing in CuteFTP, the asterisk was back.

 

I had this problem once before, a couple of years ago, I think, but I can remember neither the cause nor the solution. I would appreciate any advice or suggestions.

 

Thank you!

 

Eliz.

Link to comment
Share on other sites

FYI: In order to display "hidden" files (such as the .htaccess file), I'd set the "filter" to the setting recommended by the CuteFTP "Help" file; namely, "-rtaF". I have no idea what these letters stand for.

 

Comparing these settings with those on another account, I clicked "Enable local filters (Let CuteFTP do the filtering)" and changed the "remote" filter to "-a".

 

I don't know which part of these changes fixed the problem, but everything appears to be working properly now. :)

 

Eliz.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...