Jump to content

Using My Tch Domain For Sending Email


Recommended Posts

I have set up sending e-mail via my TCH host (rather than the Cox SMTP - my ISP).

 

It works fine, except that when my PC (using Thunderbird) tries to connect, I get a message: "the security certificate presented belongs to "server90.tch.....". When I click OK it sends the e-mail anyway.

 

I am a bit confused by this, as I don't think that my e-mail client is encrypted or using SSL.

 

Could someone explain what I need to do so that I don't get the "the security certificate.." message?

 

Martyn

 

 

 

Edit TCH-Bruce: removed reseller domain name

Link to post
Share on other sites

The only time I've seen the security cert notice appear is if I am sending secure email and once you accept the cert it goes away.

 

If you are using port 25 or 26 for sending mail you are not using SSL however if you are using port 465 you are.

Link to post
Share on other sites
The only time I've seen the security cert notice appear is if I am sending secure email and once you accept the cert it goes away.

 

If you are using port 25 or 26 for sending mail you are not using SSL however if you are using port 465 you are.

 

So, if we don't want to send our account info in the clear we should use port 465 for the SMTP (outgoing) server connection and check the SSL checkbox in the settings?

Link to post
Share on other sites
That is correct. You may receive a warning about the certificate but once you accept it you should not see it again until it's renewed on the server.

 

Yep, it works! I had just switched to 26 as had the user above. I got the message but thought it was then using SSL. I should have remembered that chart I read a few years back that explained the standard usage for certain port numbers.

 

Do you have any pull to get that put on the cPanel --> Manage Accounts --> Configure Mail Client --> Manual Settings section? (A rhetorical question not requiring an answer!)

 

Thank you!

Link to post
Share on other sites

That seemed to do the trick, thanks Bruce, the message has gone away.

 

In Thunderbird there are 4 options:

 

none,

TLS(if avaialble),

TLS,

and SSL

 

I had inadvertantly (or it defaulted) ticked the TLS (if available option). I changed it to "none" - and it works fine.

 

Out of curiosity, what is TLS?

 

Thank you.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...