Jump to content
boxturt

Email Timing Out

Recommended Posts

My daughter, currently in Australia, has an email account provided for through one of my hosting accounts. (She's using SquirrelMail) She can reach the account and sign in just fine but is unable to open any email (regardless of size or content) as it keeps timing out.

 

I have no trouble at all from here in CT USA

 

Are there any tests she can do or suggestions I can make. I'm rather at a loss here. It's not like I can just walk down the hall and help her out. (I miss those days) .

 

Thanks bunches.

Share this post


Link to post
Share on other sites

There is a bug in PHP 4.4.1 that TCH recently upgraded to that will cause SquirrelMail to timeout when opening messages. If it's a stand alone copy you installed, try setting "$allow_server_sort = true" in config.php otherwise, you should probably open a support ticket to have the techs look at it.

 

There are also a couple lines in download.php that need to be tweaked. Details here

Share this post


Link to post
Share on other sites

One thing I've found is if I access with secure https webmail hangs. But accessing with just http it seems to work fine. Don't know how she's accessing but thought I would mention it.

Share this post


Link to post
Share on other sites

Thanks Bruce, I'll mention that to her.

 

Thanks click, interesting and it DID start happening the day the php upgrades started.

 

I'm going to try to get some more information from her before opening a ticket.

Share this post


Link to post
Share on other sites
There is a bug in PHP 4.4.1 that TCH recently upgraded to that will cause SquirrelMail to timeout when opening messages. If it's a stand alone copy you installed, try setting "$allow_server_sort = true" in config.php otherwise, you should probably open a support ticket to have the techs look at it.

 

There are also a couple lines in download.php that need to be tweaked. Details here

 

Thank you for this fix! I was wondering why I couldn't read emails all the sudden!

 

What is the implication of not tweaking the download.php lines?

Share this post


Link to post
Share on other sites
Thank you for this fix! I was wondering why I couldn't read emails all the sudden!

 

What is the implication of not tweaking the download.php lines?

Honestly, I'm not real sure... The SquirrelMail site just says:

PHP 4.4.0 and register_globals=on + SquirrelMail 1.4.5 or older

 

* Variable corruption in messages with attachments.

Share this post


Link to post
Share on other sites
Thank you for this fix! I was wondering why I couldn't read emails all the sudden!

 

Sorry to hear it but glad it's not just me. :blink:

Share this post


Link to post
Share on other sites

My e-mail has been up and down the past couple of days at least. I only use Squirrel Mail, but not the stand alone. And yes, we sign in with https.

Share this post


Link to post
Share on other sites

Yeah mine started doing this over the past 48hrs out of nowhere...

 

Fatal error: Maximum execution time of 30 seconds exceeded in /usr/local/squirrelmail-1.4.3a/src/read_body.php on line 95

 

:blink:

Edited by vrflyer

Share this post


Link to post
Share on other sites

I would start with a ticket to see if anything can be done from our end. I will say that I am not having issues with the one installed on my server though.

Share this post


Link to post
Share on other sites
Yeah mine started doing this over the past 48hrs out of nowhere...
Fatal error: Maximum execution time of 30 seconds exceeded in /usr/local/squirrelmail-1.4.3a/src/read_body.php on line 95

:blink:

That is the same error I was getting. $allow_server_sort=true should fix it.

 

BTW, 1.4.3a is an old version. Latest is 1.4.5 with, it looks like, several security fixes since 1.4.3. Looks like this is TCH's install???

Edited by click

Share this post


Link to post
Share on other sites

I submitted a help ticket at 8:56. At 9:16 I received a reply stating the problem should now be fixed for me :blink:

It was an error related to the php upgrade.

 

Now I just neeed to hear from the kid on the other side of the planet (using the account) to let me know if it is working for her.

Share this post


Link to post
Share on other sites

Australia reports kangaroo, er I mean Squirrel mail is working just fine now.

 

Thanks Kris. :thumbup1:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...