Jump to content

Email Timing Out


boxturt
 Share

Recommended Posts

My daughter, currently in Australia, has an email account provided for through one of my hosting accounts. (She's using SquirrelMail) She can reach the account and sign in just fine but is unable to open any email (regardless of size or content) as it keeps timing out.

 

I have no trouble at all from here in CT USA

 

Are there any tests she can do or suggestions I can make. I'm rather at a loss here. It's not like I can just walk down the hall and help her out. (I miss those days) .

 

Thanks bunches.

Link to comment
Share on other sites

There is a bug in PHP 4.4.1 that TCH recently upgraded to that will cause SquirrelMail to timeout when opening messages. If it's a stand alone copy you installed, try setting "$allow_server_sort = true" in config.php otherwise, you should probably open a support ticket to have the techs look at it.

 

There are also a couple lines in download.php that need to be tweaked. Details here

Link to comment
Share on other sites

There is a bug in PHP 4.4.1 that TCH recently upgraded to that will cause SquirrelMail to timeout when opening messages. If it's a stand alone copy you installed, try setting "$allow_server_sort = true" in config.php otherwise, you should probably open a support ticket to have the techs look at it.

 

There are also a couple lines in download.php that need to be tweaked. Details here

 

Thank you for this fix! I was wondering why I couldn't read emails all the sudden!

 

What is the implication of not tweaking the download.php lines?

Link to comment
Share on other sites

Thank you for this fix! I was wondering why I couldn't read emails all the sudden!

 

What is the implication of not tweaking the download.php lines?

Honestly, I'm not real sure... The SquirrelMail site just says:

PHP 4.4.0 and register_globals=on + SquirrelMail 1.4.5 or older

 

* Variable corruption in messages with attachments.

Link to comment
Share on other sites

Yeah mine started doing this over the past 48hrs out of nowhere...
Fatal error: Maximum execution time of 30 seconds exceeded in /usr/local/squirrelmail-1.4.3a/src/read_body.php on line 95

:blink:

That is the same error I was getting. $allow_server_sort=true should fix it.

 

BTW, 1.4.3a is an old version. Latest is 1.4.5 with, it looks like, several security fixes since 1.4.3. Looks like this is TCH's install???

Edited by click
Link to comment
Share on other sites

I submitted a help ticket at 8:56. At 9:16 I received a reply stating the problem should now be fixed for me :blink:

It was an error related to the php upgrade.

 

Now I just neeed to hear from the kid on the other side of the planet (using the account) to let me know if it is working for her.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...