Jump to content

Help! Flash Movies Kidnapped!


Recommended Posts

Hello everyone!

 

First, I'd like to apologize for the coming very amateurish description and question, please be patient, this is my first website designing experience!

 

So, after some struggling, I finally managed to finish my website using Dreamweaver and Flash. I inserted Flash movies in some of the html pages in Dreamweaver. When I preview my site from Dreamweaver, everything works perfectly, almost like a miracle! but not quite! When I publish my site, the Flash movies dissapear! nothing, nada, zip!

 

I tried everything! I removed sub-folders, saved my movies in the same folder as my html pages, simplified the names, made sure the path in dreamweaver doesn't point to my local computer, doesn't have a root slash in front of it. I've even used another ftp software to publish cause i read somewhere that sometimes Dreamweaver doesn't publish properly. Nothing worked.

 

On my computer, if I connect to my site, I can see the movies, but form anywhere else, i can't. This means it's still linking to my local computer for some reason right? I just don't understand why.....

 

please, please, help! going completely nuts!

 

thanks!

Link to post
Share on other sites

Hi claudym,

 

Since it is not hosted on our servers, I can not acces to check fully.

 

I can see the beginning of most of the Flash. Have you cleard your cache fuly?

 

Have you uploaded them in the correct mode (binary).

 

I also note that at least one of the swf files is hosted on a site other than your own, which can lead to additional problems.

 

Finally, there are a number of HTML coding errors, but I don't think these are directly related to any Flash problem.

Link to post
Share on other sites

Hi again,

 

Excuse my ignorance, but how do I know if I uploaded them in binary mode? I don't remember any of the dreamweaver settings asking me about modes... can I check somewhere?

 

Also, how do i clear my cache? (yes, I am a TOTAL beginner...::)

 

I haven't even tried to look at the code (well I did, but I couldn't mae much sense of it), it was all generated by Dreamweaver or Flash...

 

Do you think it would help of I publish my flash file as an html file and then open that in Dreamweaver and edit it to fit with the rest of the layout?

 

thanks again, hope I'm not bombarding you with questions!

Link to post
Share on other sites

I just republished using Smart Ftp, and I noticed the log saying "opening binary mode data connection" for one of the flash movies. So I guess that means i'm uploading in the correct mode yes?

 

Also I checked the settings in the ftp software, and emptied the cache (is that what you meant?)

Link to post
Share on other sites

I believe the cache Andy's talking about is your browser. Where it's at depends upon what browser you use. If you use IE, then it's under "Tools" and "Internet Options". If you use Firefox, then it's under "Tools", "Options", "Privacy".

 

Hope this helps and welcome to the forums!

Link to post
Share on other sites

Thank you both!

 

It worked!!!! Finally!!! i did a little dance, my dog thinks I'm nuts, but I don't care!!

 

The pages are quite slow to load though, any suggestions? I've kept everything as small as possible, when you have the time, anyone, can you please have a look and give me comments?

 

thanks a lot!

Link to post
Share on other sites
It worked!!!!
I'm glad it's working for you now :)
The pages are quite slow to load though, any suggestions?

you could move to a faster, better hosting service - such as TotalChoice Hosting ;)

 

The size of your pages are fairly small, so it should download fast enough on all but the slower dial-up connections.

 

For checking download speed and optimisation, try http://www.websiteoptimization.com/services/analyze/index.html

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...