Jump to content

I've Read The Other Dada threads.......


Recommended Posts

Thank you in advance! TCH recommended I post here and that surely you could help me.

 

I have installed, uninstalled and reinstalled everything to the Cpanel through FTP in the ASCII format.

 

I even tried someone else's thing where they change the config script to dadafiles instead of dada_filescgi then named the folder in home directory the same.

 

Ok, here's what I have.

 

dadafiles in home directory

 

dada folder in cgi-bin

 

DADA file and mail.cgi in the data folder ( / public_html / cgi-bin / dada / )

 

Config.pm like this:

$PROGRAM_ROOT_PASSWORD = '****;

$MAILPROG = '/usr/sbin/sendmail';

$FILES = '/home/mycpanelname/dadafiles';

$PROGRAM_URL = 'http://www.mydomainname.com/cgi-bin/dada/mail.cgi';

 

When I go to the program url I get this:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@my-TCH-domain.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

 

So I have done something wrong but have gone over it a kagillion times and can't find it!

 

Any suggestions?

Debi

SevenAcres Farm

 

 

EDIT: TCH-Bruce - changed email address to prevent spam harvesting

Link to post
Share on other sites

Hi and welcome to the forum, Debi. :)

 

I am not sure I understand your folder & file structure, but do you have it like this:

cgi-bin which have a folder named dada and in that another folder named DADA and in cgi-bin/dada a file named mail.cgi?

 

Also, note that the DADA folder must be with upper-case letters.

 

Another thing is to see so dada_files are placed outside the public_html and if all folders and mail.cgi have the proper permission.

Link to post
Share on other sites

Same here, I am not sure what else to change.

 

I created folder dada_files above public_html

 

I created dada folder in cgi-bin and then uploaded DADA and mail.cgi into dada.

 

I have

 

$PROGRAM_ROOT_PASSWORD = '********';

$FILES = '/home/cpanel login name/dada_files';

$MAILPROG = '/usr/sbin/sendmail';

$PROGRAM_URL ='http://www.thecheapgifts.com/cgi-bin/dada/mail.cgi';

 

And still when I try to use url http://www.thecheapgifts.com/cgi-bin/dada/mail.cgi it gives me HTTP 500 internal server error.

 

Please someone tells me how to do it :P

Link to post
Share on other sites

Not sure what the problem is but I did some searching through google and for the "500" errors one of the results says:

 

Check to see that you:

 

*

chmoded 755 the mail.cgi script

 

*

uploaded the mail.cgi script, as well as all the script files that are in the DADA folder. The directory structure on your server should look exactly like its layed out when you downloaded the script and all its files.

 

*

Make sure you uploaded the mail.cgi script and all the script files as 'ASCII' and not binary.

 

*

Make sure all the files are uploaded without their case being changed. Also make sure they were uncompressed without their case being changed.

Link to post
Share on other sites

Just thought I would mention that I am also having this problem. After poking around a bit I did discover that my "/dada/DADA" was actually "/dada/dada/" So I fixed that. Nonetheless even after that correction there was still same error.

 

I am beginning to suspect that the cgi files were not uploaded as ASCII as the instructions say, but rather as binary. (I was simply trusting my ftp program to do the proper thing.) I am going to try and manually upload the cgi files as ASCII and see if that fixes my problem.

 

Otherwise I come crying back to here. :P

Link to post
Share on other sites

Waaaah!

 

Okay, how does one tell for certain if a file is being uploaded in binary or not? I've tried uploading in both smartftp and gftp (from both windows and linux machines) and even though I set both to use ASCII as soon as I start uploading mail.cgi it says

 

>150 Opening BINARY mode data connection for /public_html/cgi-bin/dada/mail.cgi

226 Transfer complete.

 

It says this even though I have it set to transfer via ASCII. What gives? Should I just ignore what it says, or is somehow my smartFTP and my gftp acting weird when everyone else is not.

 

But maybe that is not the problem. My error log says:

 

[2005-10-27 14:53:38]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

[2005-10-27 14:49:54]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

[2005-10-27 14:43:49]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

[2005-10-27 14:43:46]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

[2005-10-27 14:00:18]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 14:00:16]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:53:04]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:52:57]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:40:19]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:38:27]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:38:24]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:35:00]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:34:42]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:18:11]: error: directory is writable by others: (/home/username/public_html/cgi-bin/dada)

[2005-10-27 13:14:54]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

[2005-10-27 12:39:43]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

[2005-10-27 12:39:25]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

[2005-10-27 12:34:37]: error: file is writable by others: (/home/username/public_html/cgi-bin/dada/mail.cgi)

 

And in a different place it says:

 

[Thu Oct 27 14:43:49 2005][error] [client 64.185.141.27] Premature end of script headers: /home/username/public_html/cgi-bin/dada/mail.cgi

 

I don't understand what it means (or why it is an error) when it says "error:directory is writable by others" and "error: file is writable by other" so I can't fix that problem until someone kindly enlightens me.

 

I suspect the error "premature ending of script header" is telling me (maybe) that the file was uploaded in the wrong format, but it could mean anything.

 

Any help would be much appreciated.

Edited by TCH-David
Link to post
Share on other sites

The file/directory is writeable by others means that the permissions on the file/directory are set so that anyone can modify the contents of them.

 

The permission should be 755 and you should be able to change it with your FTP program.

 

As for how to tell if a file was uploaded in ASCII or Binary doesn't your FTP program produce a log as it's uploading? Looking at the log you should be able to see how they were uploaded.

Link to post
Share on other sites

Ok, I've made a bit of progress. Maybe this will help vimalus too.

 

I changed the permission on mail.cgi to 755 and that took care of my error.

 

NOTE: It seems every time I upload my mail.cgi it settings is returned to 777 and I get the error message again, so I must chmod the mail.cgi file every time I upload it!

 

However, I am still not all the way there. Now when I go to www.marilynbelford.com/cgi-bin/dada/mail.cgi I get . . . well go there and see for yourself. I get a little welcome thing, but I can't do anything. Hello? I don't think that is how it is supposed to be.

 

Any suggestions? I'm not getting any error message now, but this doesn't seem to be what I'm supposed to see.

Link to post
Share on other sites
but this doesn't seem to be what I'm supposed to see.

It´s a little bit of what you are supposed to see. :P

 

Seriously, yes you are supposed to see that the very first time you visit your dada mail installation. However there are text missing as you notice.

I have never run in to this problem, but it looks like either some files have not been uploaded or uploaded correct (i.e the ftp program messed up something).

 

Please see this page if the permissions are correct.

Apart from that, all I can think of is comparing what you have on the server vs your on computer to see that all files really have been uploaded and their structure.

Link to post
Share on other sites

TCH-Thomas -

 

You were completely correct. The problem was either missing or corrupted files. A good fresh upload brought the correct information up on my cgi page.

 

I hope vimalus and Debi manage to solve their problems as well. I strongly suggest they first try setting the permissions on mail.cgi to 755 and see if that takes care of their error message. It took care of mine.

 

(But then I had that bad install to take care of as well.)

 

Glad to have it all working. Thanks to everyone for their time!

 

Rundi

Link to post
Share on other sites

Rundi,

 

in your error log, it appears that you are displaying your cPanel login name. I'd go through and edit those out so that you don't announce your cPanel name to the world. (Or maybe one of the mods could do that for you.)

 

Glad your problem seems to be solved.

Edited by abinidi
Link to post
Share on other sites

Ah . . . yes, I suppose that would be wise. I didn't even think of that. Unfortunately I can only edit my last post, none of those previous to the most recent. So it would be nice if a mod could obscure my cpanel name for me, if they could find the time.

 

Thanks.

 

Rundi

Link to post
Share on other sites

Hi, thank you, Guys!

 

Ok, I double checked everything except for the permissions again.

 

To recap that:

 

I should make sure the dadafiles which is outside the public.html folder is 777 to write to it.

 

mail.cgi should be 755

 

No, the dadafiles folder is outside public.html

Inside the cgi.bin is a folder named dada

Inside the dada folder is a folder named DADA as well as the mail.

 

As soon as I return from feeding I will read this entire thread and check those permissions.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...