Jump to content

Tch Forum Cookies


D.Slatk
 Share

Recommended Posts

For a while now I have been having problems with TCH's forums always logging me out. It happens quite frequently so after having a look around, noticed that the cookies I get here that log me in are set to expire during the end of the current session. :blink: If you don't know, a session in cookies is when your browser is open, if you close it then the session ends...

 

It seems others have their cookies working properly since their cookies expire a year after they were set. Since the cookies get removed at the end of a session, closing and opening the browser will make me have to log back in. This happens on both the desktop (uses windows xp) and laptop (uses windows 2000). Both use firefox but the same thing happens when using internet explorer. Kind of wierd. :(

 

I was wondering if anybody else is experiencing or experienced the same thing, and maybe has a fix for it? Or could know why it might be happening...

 

Thanks! :)

Link to comment
Share on other sites

You are checking the 'Remember Me' box when you log in, right? :blink:

 

The first thing I'd look at is the cookie settings in the browser:

 

1) In Firefox, click 'Tools', then 'Options' on the menu. Click 'Privacy' in the left column, the click 'Cookies' to expand the options if it's not already. Check the 'Keep Cookies' option - is it set to 'until they expire', or is it set to 'until I close Firefox'?

 

2) In Internet Explorer, click 'Tools', then 'Internet Options...' on the menu. Click on the 'Privacy' tab. There may be a slider bar on the left, allowing you to select different levels of privacy. The default is 'Medium', which includes 'Restricts first-party cookies that use personally identifiable information without implicit consent'.

 

One option is to click the 'Sites' button, enter 'www.totalchoicehosting.com' and click the 'Allow' button to always accept cookies regardless of the privacy policy.

 

What I usually do instead is click the 'Advanced' button and select the following options:

 

1) Override automatic cookie handling

2) Accept first-party cookies

3) Block third-party cookies

4) Always allow session cookies

 

If your browsers are already configured correctly to save cookies, I'd suspect that a third-party firewall or cookie blocking/managing program is running on the computer and determining on its own whether cookies will be session cookies or not.

 

Hope this helps...

Link to comment
Share on other sites

By the way as long as I keep the browser window open, I am able to stay in. It's only when I close it that I get logged out.

 

Yeah, I've checked the remember me box. :)

 

Firefox is set to keep cookies until they expire. I also tried the "exceptions" button and add forums.totalchoicehosting.com but that didn't work.

 

I went to IE and used the settings you did (mine was set for medium there), had no results. Tried allowing the forums.totalchoicehosting.com website, didn't work either

 

This is only happening with cookies here as far as I know, other forums work fine. o.o I recently reformatted to keep things running quickly and everything and haven't gotten around to installing anything that could block bad cookies. Probably should though. :blink:

 

It is starting to just get wierd.

Edited by D.Slatk
Link to comment
Share on other sites

Firefox is set to keep cookies until they expire. I also tried the "exceptions" button and add forums.totalchoicehosting.com but that didn't work.

 

I went to IE and used the settings you did (mine was set for medium there), had no results. Tried allowing the forums.totalchoicehosting.com website, didn't work either

Although you can access the forums from forums.totalchoicehosting.com, most (if not all) of the internal links use www.totalchoicehosting.com/forums. These are different domains as far as cookies are concerned, so if you're going to whitelist a domain, I'd suggest whitelisting www.totalchoicehosting.com, and access the forums in your browser via www.totalchoicehosting.com/forums/.

Link to comment
Share on other sites

Ah, I didn't realize that! *updates bookmark* I think I just typed it in there and checked if it was right. :P I wish that fixed it though. >.<

Link to comment
Share on other sites

No >.< At least that I know of

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...