Jump to content

Server Settings Causing Cms Wysiwig Not To Work?


valerie
 Share

Recommended Posts

I'm not sure if this post goes here, so feel free to move it if you need to. I need someone to help me determine if the problems I'm having with a cms are because of the TCH servers or if it's something else. THe lead developer said it's a server problem and they can't help, but I have no way to test for this without someone else trying to use the cms and see if they have the same error. It's a lot to ask, but I thought I'd put it out there and see if someone can help. It's a really quick install. You just upload the file found here

create a mysql database, and that's it. Once it's installed what the problem to check for is if the wysiwig editor loads right. You'll need to add a wysiwig page then type some text in. If you can save the page and no extra slashes are added to a test link or any text with apostrophes, then you've got yourself a great cms and I'll know whether it's the server setup. Let me know if you run into any questions or problems.

 

Thanks!

Link to comment
Share on other sites

Worked fine for me. Make sure you have created the database, user, and added the user to the database. Also be sure you enter the information into the configuration including your username appended, i.e. the database name is cpaneluser_wb etc.

Link to comment
Share on other sites

Thanks. I was able to get through the install and have actually been using it for a couple of weeks. I get this error with the wysiwig changing the html code when I'd save the content I typed in...

 

https://www.websitebaker.org/forum/viewtopic.php?t=1081

 

Here's the forum thread on the cms forum where they said it's a server problem. I have detailed examples of the problem to check for if that helps... since you've got it installed now.

 

The lead developer, Ryan, pm'd me and told me it was the server, which is why that's not in the thread...

 

Thanks again!!!

 

EDIT: since you don't have any trouble with it, any ideas on what could be causing the problem?

Link to comment
Share on other sites

Interesting. I see how it ads the slashes in your post on the other forum over there. I am trying to create a link, I select the text I want to be a link, click the link button and put the path in. I click the ok button and get back to my typing window and see the underlined text. When I save the page and view it, there is no link at all.

Link to comment
Share on other sites

Interesting.  I see how it ads the slashes in your post on the other forum over there.  I am trying to create a link, I select the text I want to be a link, click the link button and put the path in.  I click the ok button and get back to my typing window and see the underlined text.  When I save the page and view it, there is no link at all.

 

Did it just delete it? For me, I'd get a 404 error because the slashes had made the link path unreadable by the browser.

Link to comment
Share on other sites

Now, when I go to HTML view and edit the link manually, it creates it just fine and the link works fine. No slashes. I do know that often times when working with PHP one will use a slash before things like an apostrophe so the PHP will display it and not think of it as part of the code but I am not sure how that would be an issue here.

Link to comment
Share on other sites

Ok, so that's a little different than what I had because I was trying to hard code it in html and that didn't help. Does the wysiwig load on the first page load (after it says "success" or when you first open a page) or do you have to refresh to get it to appear?

 

Thanks for all your help. I really do appreciate it. If you could paste the actual errors in this thread that would be great.

 

Thanks!

Link to comment
Share on other sites

Ok--thanks! One last question: does the link have to be edited manually to work? Or does it work in the regular view?

 

Thanks again. I'd love to hear if you have any ideas on what could be the trouble for me: something with my own setup on my computer then? I get the same errors in IE or in Firefox...

Link to comment
Share on other sites

Ok--is there any way you could show me what happens to the link if you don't edit manually? So you'd put it in in the regular view, save, then reopen and view in the html editor and see what's there? I want to be able to tell the website baker people so they can have the info for their bug work stuff they do.

 

By the way, the support here is phenomenal. I'm never going to consider another company. Thanks so much!!!!!

Link to comment
Share on other sites

Ok. The developer thinks the problem might be a setting in the php.ini file:

 

I think I have found the answer.

I did a little research, and I think it is a PHP.ini setting called "magic_quotes_gpc" - make sure it is set to on.

To understand what it does, the "GPC" part stands for Get/Post/Cookie, and the "magic_quotes" automatically puts \'s on single and double quotes.

 

I'll put in a support ticket and ask if they can either just switch it from it's current setting to the opposite or make sure it's set to on as above. It just seems that since it's adding slashes to everything maybe it should be set to off. But what do I know....

Link to comment
Share on other sites

The magic_quotes_gpc variable is set to on in the php.ini file and we cannot edit the file for a particular account. Some scripts require it to be on. You can put the following command in your .htaccess file in the folder that the script is in to change the variable:

 

php_value magic_quotes_gpc on

or

php_value magic_quotes_gpc off

Link to comment
Share on other sites

Is this why I get slashes in my WP blog when I have apostrophes in link descriptions and such? If I update any part of the link text, I then have to go back in and delete the slashes (for example, Mom's Blog ends up as Mom///'s Blog.

Link to comment
Share on other sites

It could be - searching Google for "wordpress magic_quotes_gpc" turns up a number of link to pages discussing issues like what you're describing.

 

The PHP manual indicates that 'php_flag' should be used to set the magic_quotes_gpc setting in an .htaccess file instead of 'php_value':

>php_flag magic_quotes_gpc off

...but I guess the server doesn't complain if you do use php_value. :D

 

You may also see suggestions to set magic_quotes_runtime to 'off' as well. You can indeed do this in your .htaccess file:

>php_flag magic_quotes_runtime off

...but this particular setting is already turned off on TCH servers.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...