Jump to content
Sign in to follow this  
kippez

Trouble Connecting Mysql

Recommended Posts

I have been tring to install a script that uses sql. I created the database. The program has a self install setup. so I put in database name user name and pass word but it keeps coming up withe the same error.

 

"There is an error in some of the information you provided on the previous page. The combination of server address and admin username/password you provided failed to access a valid mysql account. Please correct these values, and try again"

 

I have created new names and password in the database still does not want to connent does anyone know what i am doing WRONG

Share this post


Link to post
Share on other sites

The most common error is not having the user added to the database. The drop down boxes below where you add the database names is where this is set. Just select the username in one box and the corresponding database in the other and click on Add User to Db.

 

If you have done this, give a little more information on what you are trying to install. Perhaps someone else has installed it and can point out the secret.

Share this post


Link to post
Share on other sites

Yes I have tried this and the system still did the same thing. I put in the new name to see if maybe I was using wrong name or password. The script is weblets it is a trading app. but The admin name and password of the domain is not even connecting to the database. As I am pretty new to sql I think I may be doing something wrong but everything seems to be fine except connecting to the database so the script can install the program.

Share this post


Link to post
Share on other sites

Just a hint

 

Your username for your sql database must be parsed as

 

cpanelusernamer_databaseusername

 

and the Database name must be parsed as

 

cpanelusername_databasename

 

SO if my cpanel username was bill, my database username was headguru and my database name was gurus I would use

 

 

Database name - bill_gurus

 

Database Username - bill_headguru

 

Are you doing this?

Share this post


Link to post
Share on other sites

Yes I have been doing that I dont understand? Here is the other warning getting from script

 

Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'kipp_k@66.11.163.212' (Using password: YES) in /home/kippez/public_html/global/install.php on line 70

Share this post


Link to post
Share on other sites

I use a different program than what you are trying to use, but I got a similar error code at one point. I had one of my passwords wrong. Briefly...

 

I have a dialog box that takes care of the initial connection to the remote host...in this dialog box, my password and username had to be the same as I had been using for my regular ftp connection. In other words, if my username was "Tracy" and my password was "blue"...that is what went into this area.

 

Then I had a "connections" dialog box that dealt specifically with MySQL. In this dialog was where I had to put the username and password in like the Head Guru told you.

 

So, if you have more than one area where your connection settings are defined, you may have one of them set wrong.

 

:D Good luck...

Tracy

Share this post


Link to post
Share on other sites

I have tried that also. does not seem to work etheir.

 

Thw form looks like this.

 

The first step in setting up the webLETS system is to configure the software to access your mySQL server, and to set-up the structure and core information for the webLETS database.

 

Some of the set-up actions require administrative priviledges on your mySQL database, while the day to day operations of webLETS require only read/write access. For security purposes you may wish to configure the software with a read/write user and password. If you leave those sections blank, the system will be configured with the full admin information.

 

Database Location

 

MySQL server IP address:

webLETS database name:

 

Admin User Information

 

Admin User Name:

Admin User Password:

 

Read/Write User Information (optional)

 

Read/Write User Name:

Read/Write User Password:

Share this post


Link to post
Share on other sites

Without devulging your passwords, can you provide the information that you are entering into these form fields?

 

Tracy

Share this post


Link to post
Share on other sites

MySQL server IP address: 66.11.163.22

webLETS database name: kip_global

 

Admin User Information

 

Admin User Name: kip_kip 0r kipp

Admin User Password: password for the name choosed

Share this post


Link to post
Share on other sites

Try changing the mySQL server information to "localhost". I have no idea if that will work but everything I've ever used I've always put localhost if the database is on the same server as the site.

Share this post


Link to post
Share on other sites

That worked but now getting syntaxs error.

 

new error

You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'in(11) NOT NULL auto_increment, AccountID int(11) NOT NULL

 

Ok got that fixed

 

I was missing the a letter T in the syntaxs of the script.

 

'int(11) NOT NULL auto_increment, (should have been a t here.

AccountID int(11) NOT NULL

 

Now the error is:

 

Query was empty

 

 

Anyone know

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...