Jump to content
whoahorse

Gallery Problems

Recommended Posts

Well, my Gallery used to work..sigh..now it is telling me it cannot create thumbnails.

 

I have not tried to load photos to this gallery for some time

 

http://www.missponokastampede.com/gallery

 

but that is the error I get now.

 

Is there an easy solution to this problem?

 

Weezy

Share this post


Link to post
Share on other sites

Hi Weezy,

 

Click here and have a look at C.2. in the FAQ's and see if this helps.

 

Gail

Share this post


Link to post
Share on other sites

Hi Weezy,

 

FTP into youre gallery/config.php file, and down around line 105 or so find the line

>$gallery->app->debug = "yes";

make sure it is set to yes. This puts Gallery into 'debugging mode.

Then do an image upload again. This time when it fails it will list a bunch of reasons. If you could include the errors here I'm sure I can solve it :clapping:

 

Tom

Share this post


Link to post
Share on other sites

Hi Tom!

 

This is what I got after I put it in debug mode and tried to upload...

 

Processing status...

 

- Adding josphotos25a.jpg

Resizing/compressing original image

No resizing required

File /home/jodi/public_html/albums/album04/josphotos25a.jpg type 2.

 

 

Executing:

 

'/usr/bin/convert' -quality 90 -size 150x150 +profile '*' '/home/jodi/public_html/albums/album04/josphotos25a.jpg' -geometry 150x150 '/home/jodi/public_html/albums/album04/josphotos25a.thumb.jpg'

 

Results:

none

 

Error messages::

sh: line 1: /usr/bin/convert: No such file or directory

 

 

Status: 127 (expected 0)

Error: Unable to make thumbnail (0)!

Need help? Look in the Gallery FAQ No email sent as no valid email addresses were found

Share this post


Link to post
Share on other sites

Whispers...coppermine... :clapping:

But if you decide to continue with gallery, you really should upgrade it to the latest version. :dance:

Share this post


Link to post
Share on other sites

Hi Weezy,

 

Well it figures it's a bit different error than I ususally get.

>Error messages:: 
sh: line 1: /usr/bin/convert: No such file or directory

It is saying, that whatever 'process' the config.php is telling it to use to 'manipulate' the image, cannot be found at that location. That location is something set on the server, something you or I would have no control over.

 

But I imagine it has something to do with the paths spelled out in the config.php file for 'netpbm' or 'imagemagick' that it leading to the error.

 

At the Gallery site that Gail pointed out I found these http://gallery.menalto.com/modules.php?op=...install.faq.c.2

/usr/bin/convert: Not a JPEG file: starts with 0x0a 0x4d (/home/uspalmer/public_html/gallery/AUTHORS). -- This is a bug that has been fixed with the latest version of Gallery, please upgrade.

 

/usr/local/bin/convert: no delegate for this image format (/home/sites/home/web/albums/album_01/IMGP0215.jpg) -- This means ImageMagick doesn't have the appropriate libraries to handle a type of image format (in this case JPEG). If you have root access, make sure the appropriate image libraries are installed or ask your host to verify this. If not, you can try using NetPBM from the Gallery Download Page, which has all major image formats already included. If you are using FreeBSD and installed ImageMagick from the ports collection, see FAQ C.30.

 

Yep Thomas is right, and Gail has convinced me Coppermine is easier to install (and I know you know this too Weezy), but I just like to pain myself with the Gallery buggaboos :thumbup1:

 

It will be late evening before I can get back at this. Do you have another Gallery install, on the same server, that works? If so, you can look at its config.php, and find what is different as far as 'graphic' manipulators and the paths to them.

 

Have fun at it today :lol: Tom

Edited by tomowa

Share this post


Link to post
Share on other sites

Hi Weezy,

 

Yes, Gallery can be a real pain to install and configure compared to Coppermine. You almost need someone guiding you every step of the way if you are configuring Gallery - especially if you haven't done it much before. I just installed the new version - the first page had 7 warnings (1 serious) if I remember correctly. I did get rid of the warnings that needed to be dealt with after getting some help from TCH David and Tom. I just finished revamping some guidelines for installing Gallery and I have 14 screen shots to help the old memory. :thumbup1:

 

Anyway, that doesn't answer your question. I would agree with Thomas. If you wish to keep those photos in Gallery, then upgrade to version 1.5 which was recently released. It supposedly fixes some bugs and this may address your problem. It is also my understanding that this is a policy of TCH (that we keep our scripts current) so maybe now is the time to upgrade when you are having problems. Or, you may want to put those photos in Coppermine Photo Gallery.

 

If you decide to keep Gallery and upgrade, click here for instructions.

 

Keep us posted.

 

Gail

Share this post


Link to post
Share on other sites

Thanks for all your help guys!

 

I think I will just change over to coppermine. I really have no faith in gallery anymore. LOL

 

Weezy

Share this post


Link to post
Share on other sites

No should I?

 

I feel like I have been bugging them enough lately..

 

Weezy

Share this post


Link to post
Share on other sites

Hi Weezy,

 

I would, from the error you're getting it sounds as if the convert function is not installed on that server.

Share this post


Link to post
Share on other sites

YAY!

 

Rick fixed my problem.

 

For reference, this is what was wrong.

 

I made one change to your config.php file to change the path to Image::Magick to /usr/local/bin/ instead of /usr/bin.

 

THANKS RICK!

 

Weezy

Share this post


Link to post
Share on other sites

Glad your going :)

Share this post


Link to post
Share on other sites

Me too! I loaded her photos last night no probs :thumbdown:

 

Weezy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...