Jump to content
TCH-Thomas

Phpbb 2.0.14 Released

Recommended Posts

I've done the update manually. Can't say I saw that much that could be classed as security fixes. Some of it was just replacing $_SERVER with $HTTP_SERVER_VARS.

Share this post


Link to post
Share on other sites

2.0.14 just addressed some minor bug fixes as far as I know there were no major exploits in 2.0.13 so I was surprised that the phpBB Group released this version.

Share this post


Link to post
Share on other sites

Whilst there are no known major exploits with version 2.0.13, there are a couple of minor issues which have been fixed in version 2.0.14. Hence we Thomas has informed folk here so that they can upgrade.

 

This upgrade also protects the server load better on intensive searches - hence another very good reason to upgrade :blush:

 

Thanks for letting us know of the upgrade Thomas :unsure:

Share this post


Link to post
Share on other sites

Hello Thomas,

 

Good information. :clapping:

 

It is possible to make upgrade phpBB 2.0.11 directly to 2.0.14 ?

 

I`m use PHPBB in PHPNuke...

 

 

Thank´s

Share this post


Link to post
Share on other sites

Hello,

 

I made upgrade of the 2.0.11 for 2.0.14 in PHPnuke but, it sees this error:

 

Warning: main(./../includes/constants.php): failed to open stream: No such file or directory in /home/wwwmydomain/public_html/dp/modules/Forums/common.php on line 192

 

Warning: main(): Failed opening './../includes/constants.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/wwwmydomain/public_html/dp/modules/Forums/common.php on line 192

 

The file common.php it is in Forums

 

Some idea for me ?

Thank´s

Edited by paulo

Share this post


Link to post
Share on other sites

Hi paulo,

 

I have run across this also. Look in the file 'update_to_latest.php', or what ever it is. At about line 45 you will find this

 

>$phpbb_root_path = './../';

replace it so it looks like this

>$phpbb_root_path = '';

(That is 2 single apostrophe’s, not one quote symbol)

 

Then call for this page in your browser again to run it, then delete or re-name it so it cannot be ran again.

 

HTH, Tom

Share this post


Link to post
Share on other sites

It's funny because the update_to_latest.php has to be run from the install directory but you are told to delete that once used. In fact the forum wont work if it exists.

Share this post


Link to post
Share on other sites

I should quantify my statement by saying that this what I had to do, when running it from within the main phpbb directory. I never did place it in the install directory.

This is what I did, and it worked :)

Share this post


Link to post
Share on other sites

I wasn't laughing at you but at phpBB's stupid idea of making you run the update file from a directory that you have to delete before the forum will work.

Share this post


Link to post
Share on other sites

Wow forget 2.0.14, I ust installed the latest snapshot of phpBB Olympus :flex: talk about a major overhaul. A heck of a lot more powerful. Can require password complexity, force users to change password every x days, lock out a user after x failed logins and pretty much control everything from Admin.

Share this post


Link to post
Share on other sites
Wow forget 2.0.14, I ust installed the latest snapshot of phpBB Olympus
Hmmm, sounds interesting........
I wasn't laughing at you

No harm, though I wasn't sure where you were coming from :huh:

I did want to make clear to paulo or anyone else, that what I pointed out would only work if installed in the top level phpbb directory, if modifying the path as I did :)

Share this post


Link to post
Share on other sites
Wow forget 2.0.14, I ust installed the latest snapshot of phpBB Olympus :o talk about a major overhaul. A heck of a lot more powerful. Can require password complexity, force users to change password every x days, lock out a user after x failed logins and pretty much control everything from Admin.

 

And I hope you realize that using a pre-release version will NOT be supported by the phpBB Group and when 3.0 is finally released there will be no upgrade script you will be on your own. You will not get any support. The purpose of those snapshots is to test and see the progress of the next major versions and should not be used on a live forum.

Share this post


Link to post
Share on other sites

Heck is that what that long message says. The message that you have to manually delete from the script before you can use it? And there was me thinking they released a new version every hour just because they cared.

Share this post


Link to post
Share on other sites
>die('This software is unsupported in any and all respects. By removing this notice (found in common.php) you are noting your acceptance of this. Do not ask support questions of any kind for this release at either area51.phpbb.com or www.phpbb.com. Support for this version will appear when the beta cycle begins');

Share this post


Link to post
Share on other sites

Time to cool down now guys. ;)

 

Remember our forum guideline:

We take the "Family" atmosphere of our forums VERY seriously! We do not tolerate ANY rudeness. Any member who is intentionally unpleasant or disruptive will receive a warning and if the member offends again the member will be banned until such time as determined by a moderator or admin.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...