Jump to content

Can't Connect To Mysqldatabase


Recommended Posts

Hello again guys. I have successfully installed Textpattern and after some troubleshooting, finally got its setup page to appear in my browser. I don't know if anyone out there has ever used textpattern, but the first thing it does is prompt you to enter information about your my SQL database. I set one up through cpanel, and I entered the following information into Textpattern prompt windows. I typed everything in as folllows:

 

MySQL login: (my databaseusername) MySQL password: (user password)

MySQL server: (local host) MySQL database: (database name)

Table prefix: (-blank-)

 

Full path to server's web root:/usr/local/apache/htdocs

Full path to Textpattern: /home/databasename/public_html/textpattern/hoos

(these were the default options.)

 

Everytime I try to connect, I get the following message:

 

Warning: mysql_connect(): Access denied for user: 'hooslog_flakcatcher@localhost' (Using password: YES) in /home/hooslog/public_html/textpattern/hoos/setup.php on line 107

 

Can't connect to the database with the values entered.

 

One thing that may be problematic is that my domain name hasn't propagated yet, and I am currently using the URL http://69.50.221.209/~hooslog/ until my actual domain name, "hoosierlogic.com" propagates. I don't know why this might pose a problem, but I can't think of anything else.

 

Any suggestions on what might be going wrong here?

 

Again, I much appreciate your help and patience with what are likely very simple problems.

 

-matt

Link to comment
Share on other sites

Hi and welcome to the forum Matt. :lol:

 

I was first gonna suggest that you write the database things like cpanelusername_flakcatcher and cpanelusername_databasename, but it sounds like you did that. If not please try it. :lol:

 

Also, your hoosierlogic.com works fine from Sweden so its probably fully propagated very soon. :)

Link to comment
Share on other sites

Welcome to the forum Matt  :P

 

Did you get it working?

 

I solved that problem, but have encountered another one upon installing Textpattern, and haven't been too successful getting help from the folks at their forum, so I thought I'd try here.

 

After one successfully installs textpattern, he is asked to paste some simple php script from a window into his php.config.default file. After having some trouble with that, I found out that I had to rename the file either A) config.php, or :clapping: php.config.

 

It seems like option A would make more sense (at least to this novice) but neither one yields the correct results.

 

Because after I do this and then attempt to access the main Textpattern interface which takes me to the following URL:

 

http://hoosierlogic.com/tp/textpattern/index.php,

 

I see this message:

 

 

Warning: main(./config.php): failed to open stream: No such file or directory in /home/hooslog/public_html/tp/textpattern/index.php on line 16

 

Warning: main(./config.php): failed to open stream: No such file or directory in /home/hooslog/public_html/tp/textpattern/index.php on line 16

 

Fatal error: main(): Failed opening required './config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/hooslog/public_html/tp/textpattern/index.php on line 16

 

Any ideas on what I am doing wrong here??? I'm going crazy with this.

 

 

Thanks again for all your help.

 

-Matt

Link to comment
Share on other sites

I solved my problem -- after several tries. Strangely enough, it only worked after I edited my config.php file using cPanel's file manager page. I had been using Dreamweaver before. Wonder why that caused problems...?

 

Anyway, I'm sure I'll be around again soon with more asinine questions.

 

best regards,

Matt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...