Jump to content
Sign in to follow this  
Head Guru

Php Security And Upgrade!

Recommended Posts

Description:

Multiple vulnerabilities have been reported in PHP, where some have an unknown impact and others can be exploited by malicious people to cause a DoS (Denial of Service).

 

1) Errors within the "php_handle_iff()" and "php_handle_jpeg()" functions called by the "getimagesize()" PHP function can be exploited to cause infinite loops and consume all available CPU resources via a specially crafted image.

 

This has been reported in versions 4.2.2, 4.3.9, 4.3.10, and 5.0.3. Other versions may also be affected.

 

2) Multiple unspecified security issues exist in the exif and fbsql extensions and in the "unserialize()" and "swf_definepoly()" PHP functions.

 

Other bugs have also been reported where some may be security related.

 

Solution:

Update to version 4.3.11 or 5.0.4.

http://www.php.net/downloads.php

 

As of this morning all TCH servers have been upgraded to php 4.3.11

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...