Jump to content

Weird Error 404 Page


Recommended Posts

Hello,

I am not sure this is the right forum to post this, please move it accordingly and accept my apologies for the trouble.

 

Since the HD crash on S40 the other day the normal error 404 page has now being replaced by the following page when linking to a non existing page or clicking on a broken link:

http://server40.totalchoicehosting.com/404.shtml

 

The page displays a cPanel maintenance message on a cPanel colored page:

"cPanel Maintenance Notice

We are currently experiencing server issues. Our hosting company is working as quickly as possible to get our site back up. Please check back soon."

I find really odd that the cPanel Backup maintenance only appears when trying to access a broken link or a non existing page whilst there is no such maintenance announcement when accessing my cPanel page!! :)

 

Any ideas on how to get back the normal error 404 page?

 

Thanks in advance for your help. :)

Link to comment
Share on other sites

Hello TCH RobertM,

 

Thank you very much for your reply,

 

I have now submited a ticket and one of the tech slaped a quick solution back at me which is working but do not seem to be working the same way as before and certainly do not suit my requirements specialy when he suggested that, to make it work properly, I should design my own error pages. I have now a blank page with the message "Wrong Page" in it. :excl:

 

Form the Tech:

Just edit the 404.html present in your public_html directory and add what ever page you want to have.

And closed the ticket :dance:

 

I must admit that I am bit disapointed here... as I have been highlighthing to this technician , it feels a bit odd that after beeing with TCH for more than a year I never had to do anything about Error pages, when a link failed the visitor was sent to a default error page (i.e.h**p://www.oscommerce.info/o) explaining the situation.. Where are these gone?

 

Also the technician has actually modified my public_html .htaccess by adding:

ErrorDocument 404 http://www.aticka.com/404.html to it and created a 404.html in the Public_html folder.

Ok fair enough but after checking the same .htaccess file from my full backup (made the day before the crash) I can't see such a thing as redirect to 404 pages or any redirect to error pages for that matter and the same apply to the 404.html page he created which do not exist in this level either in my backup. :shocking:

Does this also means that I will need to create a new page for every other errors? This must be a joke!! :)

 

I have reopen the ticket explaining the situation in great detail... But until now I haven't had a reply... I believe that you are busy and also understand that this matter has no extreme urgency... Still I would be gratefull if this little problem could be looked into it when it is more convenient to allow the return of the default error pages without the hurddle of having to create new one from scratch and also without having to add anything into the .htaccess to redirect to them.

-Unless I am proved wrong, it was not needed before it shouldn't be needed now-

 

Really I am sorry for the rant but this time I feel that tech support didn't live up to expectation and trust that we will find a very fine solution soon to sort this problem out.

 

Thank you again.

Link to comment
Share on other sites

Deep Breaths Monty -

 

I had to read your ticket over and over again to understand what the problem was. In fact my initial response was hmm, my tech did a really good job on this issue. Abdul showed the client how to setup error codes in his .htaccess file and wow he just did a good job. AFter your last reply I was really confused.

 

Anyways, I finally understood the problem.

 

I have corrected the issue and your site should now be performing as it used to.

 

Bill

Link to comment
Share on other sites

A good night sleep always helps :)

 

Please accept my apologies for my somewhat lousy explanation if this was the case :oops:

Everything is now back to normal :)

 

Although, to come back on Bill's comment, I would like to highlight this.

As you are aware, I am not on tech support every and each time I have a tiny problem, I normally try to deal with them myself (as long as they are within my reach or accessible to me).

This being said, while submitting my ticket and before that ticket reached the tech, a FAQ page with answers to common problems appeared, on this page a section explaining how to modify the .htaccess to redirect to custom error page was present, I read it but decided to go ahead with the ticket as this wasn’t the answer I was looking for (if that had been the case, trust me I would have acted accordingly and not bothered to disturb tech support which I believe had probably more important issues to deal with)

 

After a few minutes Abdul came back to me with supposedly the problem sorted out and like you I thought wow as usual those guys are so efficient and quick… Amazing!!

Although after trying and checking that everything was back as before, it wasn’t and the tech had done exactly what was suggested in the FAQ… Lets face it, I am far to be a guru but as I was insisting about this problem claiming that his change(s) weren’t what I was looking for (confirmed by comparing my.htaccess and Public_html backup), maybe at this point Abdul should have taken my “badly explained” point into consideration and try to look deeper into it instead of slamming the door in my face (by closing the ticket) which I thought, was a bit off!!

 

Anyhow no harm done, I will try next time to be a bit more thorough in my explanations!!

Thank you to all the people involved for their patience & dedication in trying to sort out this tiny problem especially to TCH_RobertM for his extreme courtesy and extreme attention as well as to Head Guru for taking the matter into his hands to make sure their customer is happy and I am!! :)

Link to comment
Share on other sites

Montty: Glad to hear your situation was resolved. What else can be said about a company when the owner steps in to help? :)

 

Just thought I'd add a "FYI" for you or anyone else following this thread. Because of the way our help desk works, whenever a tech has looked at a problem, the ticket becomes closed. It's not a "door slam", but just how the software works. If the results are not what you exepected, then simply reopen the ticket as you did. (I've even had to do it myself on occasion!)

 

Again, glad to hear things are back to normal.

Link to comment
Share on other sites

From TCH-Steve:

Whenever a tech has looked at a problem, the ticket becomes closed. It's not a "door slam", but just how the software works.

I sure shall remember this one!! :)

 

Thank you TCH-Steve for underlining the fact - Very helpfull indeed!!

 

Actually, for the sake of learning, and for everyone which like me might have been through the "Default error page loss", I would love to know if this problem could have been sorted by myself (being on a shared server) and if so how?

 

Again thank you to everyone :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...