Jump to content
kjarrett

Can't Update Wordpress Options.php

Recommended Posts

I've had this problem for a while but thought it was something I had done that would go away when I upgraded to 1.5 ... nope.

 

I am trying to update the options page for my blog to include entries for my comment blacklist. When I do I get this:

 

>>>

Not Acceptable

An appropriate representation of the requested resource /blog/wp-admin/options.php could not be found on this server.

 

Apache/1.3.33 Server at www.kevin-jarrett.net Port 80

<<<

 

Someone on the Wordpress Support forums who happens to have their blog hosted here @ TCH wrote this:

 

>>>

I've encountered the same thorny problem. What happens is that the hosting company decided to use something like mod_security to deflect possible spam-tainted data before it reaches the Apache server. Problem is, when people have a list of ban words and try to update WP's options (../wp-admin/options.php), mod_security sees that list and thinks it's spam-tainted. This occurs even when you're not trying to change the blacklisted words, because the form sends out all the data including the list. Deleting the list should solve the problem but at the cost of bloggers not having control over what to ban.

<<<

 

Can anyone help?

 

I'd hate to have to move my three domains (including the one for my school) but this is not acceptable. I need to be able to update this page.

 

I've checked the permissions and they're ok, tried several alternatives, nothing helped.

 

Thanks, kj

Share this post


Link to post
Share on other sites

kj, sorry to hear you're having problems :clapping:

 

I don't know how mod_security works or how it is implemented here at TCH so I'd suggest you open a help desk ticket explaining the situation, so the techs can tell you what can be done.

Share this post


Link to post
Share on other sites

Hi kj,

 

Are you using Spam Karma by chance? If yes, delete the entire blacklist. It's now part of Spam Karma 1.18.

 

I had the same problem on two of my sites.

Share this post


Link to post
Share on other sites

Thanks for the replies gentlemen. I am not using SpamKarma, though I once was. I deleted everything in the blog folders when installing/upgrading to 1.5 Strayhorn.

 

I did open a ticket, though for now I have dealt with the comment spam issue, thanks to the most delicous and highly lethal plugin, Kitten's Spaminator. Kills comment spam DEAD. I never even see the posts, though I am enjoying all my notification emails coming to my mailbox:

 

[http://www.kevin-jarrett.net/blog] Spaminator: Spammer caught!

 

Wheeeeeeeeeeeeeee! TAKE THAT YOU SCUM SUCKING COMMENT SPAM LOWLIFE!!!

 

I'll turn off the email notifications eventually, but, they're just too much fun to watch!!!

 

BWWWWAAAHAHAHAHAHAAAAAHAHAHAAA!!!

 

-kj-

 

p.s. Yes, it's the little things that make life worth living. ;-)

Share this post


Link to post
Share on other sites
The latest Spam Karma even takes care of trackback spam. I've been happy with it.

 

I was using SK previously. Was OK, and killed comments well, but I couldn't figure out how to stop getting emailed and asked to "approve comments" that it had killed.

 

Kitten's Spaminator is SO simple, SO easy, and SO powerful, I don't think there is any comparsion. One thing is certain, if SK is working for you, don't change!

 

-kj-

Share this post


Link to post
Share on other sites

I'll have to check out Kitten's Spaminator but I have never been emailed to "approve comments" SK killed. Are you sure you had both the WP discussion options and SK options configured correctly?

 

I'm not pushing SK but I have not had a spam comment since installing it. (knock on wood).

Share this post


Link to post
Share on other sites
I'll have to check out Kitten's Spaminator but I have never been emailed to "approve comments" SK killed.  Are you sure you had both the WP discussion options and SK options configured correctly?

 

I'm not pushing SK but I have not had a spam comment since installing it. (knock on wood).

 

I must have, but, I could never figure it out. :-)

 

-kj-

Share this post


Link to post
Share on other sites

>>>

I've encountered the same thorny problem. What happens is that the hosting company decided to use something like mod_security to deflect possible spam-tainted data before it reaches the Apache server. Problem is, when people have a list of ban words and try to update WP's options (../wp-admin/options.php), mod_security sees that list and thinks it's spam-tainted. This occurs even when you're not trying to change the blacklisted words, because the form sends out all the data including the list. Deleting the list should solve the problem but at the cost of bloggers not having control over what to ban.

<<<

 

...

 

Ok, I deleted my common spam words from the Options>Discussion panel, and I was able to update.

 

As far as SpamKarma goes, my use in the past supposedly caused my server here to crash so I've disabled it. Has that issue been fixed? I've upgraded to WP 1.5 now.

 

Thanks for all your help.

Share this post


Link to post
Share on other sites
As far as SpamKarma goes, my use in the past supposedly caused my server here to crash so I've disabled it. Has that issue been fixed? I've upgraded to WP 1.5 now.

 

Your use of SpamKarma was a problem due to the version of SpamKarma and the version of WordPress combination that you were using (bug in SpamKarma caused the problem). The newer version of SpamKarma that was available even at that time fixed the problem, so you should be fine to install a current version of SpamKarma.

Share this post


Link to post
Share on other sites

Thanks for the help everybody. Glad to hear that the problem with SpamKarma has been rectified. I liked it - very efficient. But I did'nt want to get 'kicked off' of TCH as a result. :thumbup1:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...