Jump to content

Mt 3.15


chroniker
 Share

Recommended Posts

:goof: I'm following the instructions found here - totalchoicehosting.com/help/id76.htm

 

After a couple of reinstalls and messing with permissions I am able to progress to Step 5 "Run MT-Load Utility". When I do, I get -

Bad ObjectDriver config: Connection error: Access denied for user: '@localhost' (Using password: YES).

 

Obviously I used a stronger pw when setting up the MySQL db, I have added a user and I have put the pw in mt-db-pass.cgi

 

Also, I have checked my errorlog and found -

Premature end of script headers: /home/demesne/public_html/mt/mt-load.cgi

 

and

 

Premature end of script headers: /home/demesne/public_html/mt/mt-check.cgi

 

Anybody here have any ideas on what I'm doing wrong?

 

By the way, being a newb, I was not aware that cgi's are exicutable and after reading where six apart says to set permissions to 755 on all cgi's I was able to make it to step 5. You may want to see about including this in your install instructions.

Link to comment
Share on other sites

In your mt.cfg change

>Database <cpanelname_dbname>
DBUser <cpanelname_user>

To

>Database cpanelname_dbname
DBUser cpanelname_user

 

And uncomment the following lines.

 

DBUmask 0022

HTMLUmask 0022

UploadUmask 0022

DirUmask 0022

 

:D ;) ;) :)

 

My thaks to TCH-Dick and the author of MT-Medic.

 

A

Link to comment
Share on other sites

I have told it to rebuild all files several times.

 

Did you configure the weblog? Instructions for that are at

http://www.movabletype.org/docs/mtmanual_w...fig.html#weblog configuration

 

Usually the first things I do are:

1. Install the software

2. Login using the default Melody/Nelson login

3. Go change Melody/Nelson to what I want my username and password to be, via "Edit Your Profile"

4. Go to "Config Weblog" under the default blog "First Weblog"

5. Adjust the blog name to what I want and the paths to where I want the blog to show up

6. Set my local time

7. Click save at the bottom

8. Go to Preferences

9. Choose my preferences - default language, whether I'll allow comments or trackbacks, etc.

10. Click save at the bottom

11. Go to Archiving

12. Add Category archiving and make sure the box is checked

13. Click save at the bottom

14. Rebuild the blog using the "Rebuild Site" button on the lower left menu.

 

And the blog (albeit empty) shows up. Did you do all those things?

 

-Iki

Link to comment
Share on other sites

I uploaded to the server before unpacking the tarball and made all of my config changes there. When I was finaly able to run mt-check.cgi and mt-load.cgi, everything showed good to go.

 

I did the 14 steps you mentioned but when I rebuild I return to my admin main page and when I view my site all I get is my index page and I have cleared my cache on the 3 pc that I have access to at two different physical locations.

Link to comment
Share on other sites

It's not your PC.

 

Your blog isn't in your root directory, that's why you can't see it. It's publishing to a directory called "mt". That's the software's default behavior; you didn't change the weblog configuration to put it in the root directory. That'd be step 5. :)

 

Also, it shows up with no style because in your index template you're saying the stylesheet is located in your root directory, and it's not - it's probably also located under the "mt" directory because you didn't change the configuration.

 

-Iki

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...