Jump to content

Importing Data From Existing Invision Board


TOWebstress
 Share

Recommended Posts

Hi everyone! I'm new here, having just signed up with TCH yesterday. :P

 

My Web site is currently hosted on another service (not using a cPanel), and I am running Invision 1.2 on it. I would like to import all my registered users and discussion archives onto my new account at TCH as seamlessly as possible.

 

I've set up my site at TCH, but have not yet switched the DNS until I'm closer to ready for the switch. I've installed Invision on the new site.

 

Is there a tutorial somewhere for moving this information over?

 

Thanks!

Link to comment
Share on other sites

Welcome to the family and forums! :P

 

Did you install the same version of Invision here as at your current site? If so you should be able to make a backup of your current databases and import them here.

 

Sorry I don't know of a tutorial but others here may have some ideas.

Link to comment
Share on other sites

Yes, I installed 1.2 here, and that's what I've got running on the other site.

 

I'm really not very familiar with msSQL databases, how to make back-ups and move them. So any hints would be welcome. In the meantime, I can poke around and see what I find.

 

Would I find the ability to backup in the admin panel for mySQL? Urgh...now just to get in there. It just keeps timing out. I'm so glad I'm leaving that host!!

Link to comment
Share on other sites

In MySql > scroll to the bottom to find phpMyAdmin (or where ever it is on your old host)

select database > export > click on select all

check off save as file

for compression select none if small or gzipped if big

click on GO

save to a folder on your computer.

 

install your forum here via cpanel > addon scripts > invision board

then goto phpMyAdmin here select the database for the forum,

may be the only one.

Then click on SQL > goto down to Location of the textfile:

browse to the file on your computer

leave autodetect on, and click on go

if the export is from the same version you will set.

The board may not function properly until propagation fo the domain to TCH

you can edit the config_global.php file

make a copy of the original to uload later

find all lines with http://yourdomain/otherstuff

replace with your ip/~username/ from your welcome e-mail

 

that should get you started, post back if you have any trouble.

 

oh yes

:dance: Welcome to the Family :dance:

 

and your new home!

 

We really are like family here.

So if you need anything,

just ask your new family!

We love to help :)

Link to comment
Share on other sites

Thank you for those great instructions, Don. That's fabulous!

 

I followed along right there with you until it came to actually importing that database into my TCH one. I followed all the steps up to "leave autodetect on and click go"

 

I clicked go and waited. Eventually it gave me the following error:

 

"MySQL said:

 

#1044 - Access denied for user: '[mydomain]@localhost' to database '[mydomain]_com_-_db' "

 

 

Do you know it would deny me access?

 

I initiated the process of propogating the site, so it should start moving over very soon. Would that be part of the problem? Thanks again for your help.

Link to comment
Share on other sites

They are both v1.2. Are there further version codes I should be comparing?

 

The propogation is now complete. It's strange...I think it did move some stuff over. I was able to log in using my old username/password, and it recognized me as admin. So that was great. But none of the old posts/discussions are there.

 

I expected to have to fix the appearance of the board (skin, graphics, etc.), but how do I make those discussion threads appear? If I simply create the forums with my new board, will the threads know to appear there?

Link to comment
Share on other sites

Another update...I've been toying with this for hours now. I've uninstalled and re-installed IPB twice and down countless exports and imports on this database.

 

In the end, my big problem appears to be that when I import the tables from the old database, I get errors saying that they already exist. This causes an error which halts the whole process. The errors look like so:

 

MySQL said:

 

#1050 - Table 'ibf_admin_logs' already exists

 

Is there something I should be doing to force the tables I'm importing to overwrite the existing ones that came with the clean install?

 

Many, many thanks for your help on this...I really appreciate it!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...