Jump to content

Installing Dada Mail Script


Recommended Posts

Hey guys - I need a little help here.

 

I am following the directions on this page:

 

INSTRUCTIONS

 

I am now on the last step where it says the following:

Log into your hosting account using your FTP program and navigate to your cgi-bin. In your cgi-bin, create a directory called, dada. Navigate into the dada directory you just created.

 

Upload the mail.cgi script and the DADA directory from the distribution that you downloaded into this newly created directory (dada) that's in your cgi-bin.

 

Chmod 755 the mail.cgi script.

 

Visit the mail.cgi script in your browser (Hint: It's the URL you set the $PROGRAM_URL to). If all goes well, you should see this screen:

I uploaded everything (in binary) and CHMOD my mail.cgi file to 755. When I type in the address (http://www.marigoldgo.com/cgi-bin/dada/mail.cgi), I get a 500 error that says the following:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@marigoldgo.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

 

--------------------------------------------------------------------------------

 

Apache/1.3.31 Server at www.marigoldgo.com Port 80

 

Any idea what I am doing wrong?

Link to post
Share on other sites

Oh and here are the variables (I removed the password one becuase you don't need to know that ;) )

 

$MAILPROG ='/usr/sbin/sendmail'; $FILES ='usr/home/marigol/dada_files'; $PROGRAM_URL ='http://www.marigoldgo.com/cgi-bin/dada/mail.cgi';

Link to post
Share on other sites

Hi,

 

 

Welcome to teh Family ;)

 

I don't use Dada mail myself - someone who does will be along shortly but

 

a. I think the usr/home/marigol/dada_files should be /home/marigol/dada_files

 

and

 

b. If you go into cpanel, and look at the error log file (near the stats usually) it should give you some more info about the error.

Link to post
Share on other sites

I tested it the following ways:

 

1. I changed /usr/home/marigol/dada_files to /home/marigol/dada_files

Uploaded it, tried running the script, no go.

 

2. I left the above change in and changed /usr/sbin/sendmail to /sbin/sendmail

Uploaded it, tried running the script, no go.

 

3. Changed everything back to /usr/home/marigol/dada_files and /usr/sbin/sendmail just to see

No go.

 

Not sure what i am doing wrong =/

Link to post
Share on other sites
[Fri Oct 22 17:12:09 2004][error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:12:09 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:12:09 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:12:09 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:12:08 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:12:08 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:11:39 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:11:39 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:11:14 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:11:14 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:11:14 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:11:14 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:11:14 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:11:14 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:52 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:52 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:52 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:52 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:52 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:52 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:50 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:50 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:50 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:50 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:50 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:50 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:48 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:48 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:13 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:13 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:13 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:13 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:13 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:13 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:11 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:11 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:10 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:10 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:10:10 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:10:10 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:09:35 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:09:35 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:09:35 2004] [error] [client 205.67.232.50] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:09:35 2004] [error] [client 205.67.232.50] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

[Fri Oct 22 17:09:35 2004] [error] [client 205.67.232.51] File does not exist: /home/marigol/public_html/500.shtml

[Fri Oct 22 17:09:35 2004] [error] [client 205.67.232.51] Premature end of script headers: /home/marigol/public_html/cgi-bin/dada/mail.cgi

Link to post
Share on other sites

Lets double check some things.

 

using ftp goto your account

and goto the root (above public_html)

there should be a folder dada_files (lower case) with permissions of 777

 

inside public_html/cgi-bin

you should see a folder dada (lower case) permission 755

 

inside of public_html/cgi-bin/dada/

you should see a folder DADA (upper case) permisions of 755

and the file mail.cgi permissions of 755

 

inside of public_html/cgi-bin/dada/DADA folder is Config.pm

where you changed the parts according to the instructions you linked to

 

 

file (Config.pm)

find and change the parts

=cut

 

$PROGRAM_ROOT_PASSWORD = 'masterpassword';

 

=pod

 

 

and then

=cut

 

$FILES = '/home/cpanelname/dada_files';

 

=pod

 

 

and

=cut

 

$MAILPROG = '/usr/sbin/sendmail';

 

=pod

is fine

 

 

and

=cut

 

$PROGRAM_URL ='http://www.******/cgi-bin/dada/mail.cgi';

 

=pod

 

 

then goto

the above url

and create a list

 

 

let us know if that works.

Edited by TCH-Don
Link to post
Share on other sites

Ok. Here is what happened, step by step:

 

using ftp goto your account

and goto the root (above public_html)

there should be a folder dada_files (lower case) with permissions of 777

Done. All lower case. Permissions were not set to 777. I changed it to 777.

 

inside public_html/cgi-bin

you should see a folder dada (lower case) permission 755

 

Done. It's there, all lower case, and permission was and is 755.

 

inside of public_html/cgi-bin/dada/

you should see a folder DADA (upper case) permisions of 755

and the file mail.cgi permissions of 755

Done. DADA is there, all uppercase, permissions 755. mail.cgi is there, permissions 755.

 

 

inside of public_html/cgi-bin/dada/DADA folder is config.pm

where you changed the parts according to the instructions you linked to

 

Done. It was named with a capital C, I changed it to lowercase and it did not make a difference, same error. I currently changed it back to a capital C.

 

Here is what the config.pm file looks like:

 

****SNIP****

$PROGRAM_ROOT_PASSWORD ='masterpassword'; $MAILPROG ='/usr/sbin/sendmail'; $FILES ='/home/marigol/dada_files'; $PROGRAM_URL ='http://www.marigoldgo.com/cgi-bin/dada/mail.cgi';$S_PROGRAM_URL $MAIL_SETTINGS $FIRST_SUB $SEC_SUB @C $SALT $FILE_CHMOD $DIR_CHMOD $MAKE_ALL_LIST_FILES  $FOOTER $HTML_FOOTER $SUBSCRIBED_MESSAGE

****SNIP****

Link to post
Share on other sites

The first time I installed it my ftp program changed the case of file names

I used a different one

and started over from scratch deleting every thing.

 

I followed their instructions a step at a time.

If you start over and can't get it, send me a pm.

Link to post
Share on other sites

Ok. I deleted everything - redownloaded - changed variables to:

 

$PROGRAM_ROOT_PASSWORD = 'password'; $MAILPROG = '/usr/sbin/sendmail'; $FILES = '/home/marigol/dada_files'; $PROGRAM_URL = 'http://www.marigoldgo.com/cgi-bin/dada/mail.cgi';

 

CHMOD mail.cgi to 755

 

Still getting the same error. Sending PM now.

Link to post
Share on other sites
You generally have to upload cgi scripts in ascii - you specifically said that you uploaded in binary, so try it with ascii. =)

Unfortunately, that didn't seem to be the problem. I re-transferred it as ASCII and made sure the permissions were set to 755 and tried to run it again.

 

Thanks for all of the help attempts, I really appreciate it. I just have no idea what is wrong here. =/

Link to post
Share on other sites

Hi,

 

If you look further down the Config.pm I think you will see where the variables are still set incorrectly - for example;

 

$FILES = '/home/youraccount/dada_files';

 

These need to be changed - as per Don's instructions above.

Link to post
Share on other sites
Hi,

 

If you look further down the Config.pm I think you will see where the variables are still set incorrectly - for example;

 

$FILES = '/home/youraccount/dada_files';

 

These need to be changed - as per Don's instructions above.

I did change these as per my quote above:

 

$PROGRAM_ROOT_PASSWORD = 'password'; $MAILPROG = '/usr/sbin/sendmail'; $FILES = '/home/marigol/dada_files'; $PROGRAM_URL = 'http://www.marigoldgo.com/cgi-bin/dada/mail.cgi';

 

Did I mis-read your post?

Link to post
Share on other sites

I think you have changed them at line 62 of the Config.pm file - where it says @EXPORT=

 

Put if you scroll further down the Config.pm file to lines (for example lines 91 and 120) you will see where they should be set, and have not been.

Link to post
Share on other sites

Ok, GOT IT!

 

Thanks everyone for all of the help. The problem was that I was setting the silly variables in the wrong location in the Config file. After looking at yours, I saw the correct place to set them.

 

You have a lifetime customer here!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...