Jump to content

Gallery Newbie And Need Major Help


Recommended Posts

Hi guys -


I don't speak this CGI, perl, php, etc. language. I found gallery and think it'll work for me.


I've been reading the entire website and I don't understand anything. They've got documentation on how to install to:

Installing on a Unix/Linux Server with FTP

Installing on a Unix/Linux Server with Shell Access

Installing on a Windows Server (Apache)

Installing on a Windows Server (IIS)


What is all this? How do I understand it? I've read it all and none of it makes sense. I don't understand server-sides or any of this.


I'm set to download it - it's sitting in my zip file. I'm scared to extract it - I don't know where to put it or how to set it up. The manual they have on their site is too technical for me.


I'm using FP to build my website. Can anyone help me??




WAIT - - I found the tch page that explains it. Let me see if I can figure it out from there. Sorry!!

Link to comment
Share on other sites

It's one of the page errors that I created - for a file that's not showing up because I didn't load it right - I forgot the acutal file number - that's what I get for fiddling with things I'm not supposed to.




That's what the tutorial says I'm supposed to go to.


Also, I published a gallery patch first. Then realized it was a patch. I went back and downloaded the actual script and published it. so now I have a file structure of gallery(patch)/gallery(script). Is this the problem?? If so, how do I fix it?? I've tried moving files in the file-manager but I'm not figuring it out.


Thanks!! :P

Link to comment
Share on other sites

When visitng the url above I read this:

/gallery What? What happened? That page was just here! I promise. I know it was. I created it. I'm sorry. Maybe I've got my FTP files screwed up. Let me know and I'll fix it. Thanks!


Is that the error you get or is it something you have written?

Which gallery is it that you try to install, Coppermine, the gallery from menalto (which I have forgotten the name of) or something else?


Its hard to say what went wrong without knowing exactly what you did and any messages that shows up.


Generally when installing galleries and other things you ftp all files, sets eventual permissions and then run a installer. Did you do that?

Link to comment
Share on other sites



Like Thomas asked, which gallery are you installing? Coppermine, Gallery (the one by Menalto is just called Gallery) or another?


I have installed both several times. What exact error? Where are your files installed now (directory)? Did you follow the instructions in TCH's Help area? Those are really easy to follow!


PM me and I can see if I can help!



Link to comment
Share on other sites

J -


Thank you!!! I have PM'ed Groovy - but I haven't heard back from her. I'm thinking that I created a problem when I accidentally FTP'ed the Gallery patch first. I then realized it was the wrong thing. I didn't delete it and went back and got the Gallery program (or is it a script???). I FTP'ed it and that created a hierarchy of gallery/gallery. The second folder has the actual program/script in it.


could that be my problem?


Also, I've tried moving the files to the first folder, but I can't figure out how to do it.


Bless you!

Link to comment
Share on other sites

Best thing I think is to delete all files on the server that has anything to do with gallery (except for pics etc you might have uploaded) and restart. Then since you now have the correct gallery zip file you just unzip it, checks for instructions/read me, and upload and install as that read me says.


Addition: I dont know much about gallery so you might want to wait for Groovys instruction. If you had Coppermine gallery I could have helped you more.

Edited by Jikrantz
Link to comment
Share on other sites

Ahh - you're such a smart guy!! Why didn't I think of that? Good grief. I'll try that. You'd think something staring at you in front of your face...


That probably would work because I'm thinking the heirarchy is what messed it up.


Thanks! I'll let you know if it works. - - I checked out Coopermine but I couldn't understand it either. Gallery seemed more user-friendly to me. I may regret it though. ;)


Thank you again!

Link to comment
Share on other sites

Thomas & Groovy -


Welp - it worked - sort of. I'm at a place where I can't get fixed.


The final config page has an error. It told me to create a config.php folder with permissions set to 777. I did. Even created it in the gallery directory! Aren't you guys proud??


Reloaded the page again and now I get this error.



Error: File config.php is not writable by the webserver - chmod it 777 before proceeding.


I went back and set permissions again - it WAS at 777. but I undid it and did it again. Still the same error. What is chmod???


Hey Groovy! It was great talking to you!!!


Thank you!!!!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...