Jump to content

Imagemagick


LisaJill
 Share

Recommended Posts

I'm running expression engine and would like to allow it to utilize image magick; but it requires the path to it, most of the software I've run before either auto detected or guessed right; but can someone let me know the path please? =)

 

Sankoo!

Link to comment
Share on other sites

  • 8 months later...
/usr/local/bin

 

Good morning! New to the forums here & have a question about this path to IM. Is this the exact path to the script? I ask because while installing my current photo gallery, which runs perfectly in every other aspect, I designated ImageMagick and entered what you have here as the path to the script; however, I repeatedly get an error that tells me that it's the incorrect path or that IM is not installed. Since it's not the latter of the 2 issues, I thought I'd inquire as to the former.

 

I have also tried other paths named here in the forums, but none of those work, either.

 

Any help is appreciated! :) Thanks!

 

Asherah

Link to comment
Share on other sites

Yes, that is the exact path.  It works for me.... =)

 

What software are you working with?

 

Morning, Lisa! I'm using 4images. I have Coppermine installed as well but am not too happy with the fact that I can't seem to make the album private; meaning, no thumbnail views on the front page when you first visit. Thus, I've installed 4images, which I've used in the past and was pleased with.

 

To be exact, the line where I'm to put the path to IM states:

 

"If you have selected "ImageMagick" or "NetPBM", enter path and program name"

 

I've selected ImageMagick as my conversion tool, and when it asks for the path, I've entered /usr/local/bin.

 

I've also tried

/usr/local/bin/ (trailing slash)

/usr/local/bin/convert (no trailing slash)

and /usr/local/bin/convert/ (WITH the trailing slash)

 

Once the settings are saved, on ANY of the above, I click on the link that says "Auto Thumbnailer" (and even "Auto Image Resizer") and get that same error, telling me that the path is either incorrect or IM isn't installed. I can clearly see that it is indeed installed; however, it just isn't being recognized for some reason. Highly frustrating. LOL.

 

If anyone can help, I would really appreciate it. I'd like to have the album up and running [read: presentable to friends & family] as soon as humanly possible. Thanks so much! :)

 

Asherah

Link to comment
Share on other sites

Thanks for the welcome, Bruce! :) I registered my domain with you guys & signed up for hosting at the recommendation of a friend sometime last month. So far, I've been pleased. ;) I was previously on a Windows server with my old host; what a nightmare. Very difficult to design my site the way I wanted to do it. LOL.

 

Asherah

Link to comment
Share on other sites

  • 2 weeks later...

I would just like to add something here. I just installed coppermine on one of my servers tonight and took the advice for the path to ImageMagick but it didn't work. What I used was

 

 

/usr/local/bin

 

so then I changed it to

 

/usr/local/bin/

 

and it worked like a charm. So if anyone else is having trouble it may be as simple as needing the trailing slash to work.

Link to comment
Share on other sites

just wondering if the above poster who was using 4images got it working. I've neglected it for a few months and have just noticed it's no longer working for me...

 

I tried removing the 'convert' from when I originally installed, and no luck... guess, I'll submit a help ticket

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...