Jump to content


Photo

Help With Oscommerce Editing Files


  • Please log in to reply
3 replies to this topic

#1 OnlineAutorama

OnlineAutorama

    Distant Family

  • Members
  • PipPipPip
  • 141 posts

Posted 22 March 2008 - 07:54 PM

Hi, My name is Jim and i'm really hoping someone here can help me with my question please.

I'm very new to osCommerce so i'm sorry if this these may seem like easy questions but please help.

I installed OSC using Fantastico thru my server host so it was pretty much automatically installed for me but i cannot figure out how to change or solve the questions that i have.

#1.
Up top left corner in the menu area where says "Top" and "Catalog" (After a Fresh New Install) under the osCommerce logo, When i click on "Top" it takes me to http://DOMAIN NAME.com and not http://www.DOMAIN NAME.com and by doing so it shows all of the files that are in that directory instead of taking it to the index.php file.

What file do i edit or where do i go and change this so that when i click on "Top" it goes to http://www.DOMAIN NAME.com and Not http://DOMAIN NAME.com ?

It seems like an easy fix but after hours of searching thru .php files and searching the OSC Forums site including this one i am STUMPED!

Could someone assist me please?

Thank You very much in advanced.

Jim

#2 TCH-Andy

TCH-Andy

    Immediate Family

  • Members
  • PipPipPipPip
  • 4,699 posts

Posted 23 March 2008 - 03:27 AM

Hi Jim,

Can you open a ticket and tell us which domain please. The reason I say that is with or without the www should not take you to different places, it sounds as if there is an error in your htaccess somewhere.
Andy Beckett
-----------------
Part of the TCH family since the beginnings of time.

#3 OnlineAutorama

OnlineAutorama

    Distant Family

  • Members
  • PipPipPip
  • 141 posts

Posted 23 March 2008 - 08:14 PM

Hi Jim,

Can you open a ticket and tell us which domain please. The reason I say that is with or without the www should not take you to different places, it sounds as if there is an error in your htaccess somewhere.


I including the www. in configure.php file and now all is well.
The files inside the directory no longer show up. Do you think i still need to open a ticket for this and feel that there might be an error in the htaccess somewhere??

Jim

#4 TCH-Bruce

TCH-Bruce

    Volunteer Moderator

  • Members
  • PipPipPipPip
  • 19,960 posts

Posted 24 March 2008 - 07:10 AM

It would be faster to get a solution if you do open a help desk ticket. The techs can take a look. An extra set of eyes is always good.

Bruce Richards
Forum Moderator
TotalChoice Hosting, Inc.
Webhosting by Total Choice Web Hosting - General Support Forum

I am a Forum Moderator. While I can assist in answering most of your hosting related questions, I am unable to answer questions about specifics relating to your account such as billing and server related issues. Should you need assistance in these areas, please contact our Help Desk or our many other options. Another good place to find answers is with our help pages, tutorials and movie tutorials.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users