Jump to content


Photo

Have In/out Links, Not Showing Up? What Can I Do


  • Please log in to reply
2 replies to this topic

#1 Vintage Lover

Vintage Lover

    Family Friend

  • Members
  • PipPip
  • 73 posts

Posted 03 September 2005 - 07:05 PM

Hi everyone. I know I need to be patient. My site is new. I have several questions though.

1. I have incoming and outgoing links. I even have a links page and have exchanged links with several well visited websites similar to mine. When I type in my url in Google's search engine, no links show up for incoming links. Why???

2. Can you give me suggestions on what to do with my pages to get more google bot hits? Do I need to add links to my other pages within the content, or are the nav menus enough?

3. Do I need a sitemap?

www.debutanteclothing.com

Thanks in advance,
Sandra

#2 TweezerMan

TweezerMan

    Immediate Family

  • Members
  • PipPipPipPip
  • 1,763 posts

Posted 03 September 2005 - 09:49 PM

1.  I have incoming and outgoing links.  I even have a links page and have exchanged links with several  well visited websites similar to mine.  When I type in my url in Google's search engine, no links show up for incoming links.  Why???

<{POST_SNAPBACK}>

Google has to crawl and index the other sites that have linked to you, which does take time. Also, I don't believe Google updates the incoming links index as frequently as the content index (not sure about that, just something I heard somewhere).

2.  Can you give me suggestions on what to do with my pages to get more google bot hits?  Do I need to add links to my other pages within the content, or are the nav menus enough?

<{POST_SNAPBACK}>

The Googlebot should be able to follow your site's nav menu links to find the rest of your site's pages. It should find them in all in time.

3.  Do I need a sitemap?

<{POST_SNAPBACK}>

I don't think so, but that's just my opinion. ;)
David Phillips (TweezerMan)
The Tweezer's Edge v3

#3 Vintage Lover

Vintage Lover

    Family Friend

  • Members
  • PipPip
  • 73 posts

Posted 03 September 2005 - 11:33 PM

Thanks David! I jsut got done following the SEO tutorial. I have added META tags, just in case. I also added TCH's link to my main page and ready to request a link back.

Sandra




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users