Jump to content


Photo

Problems Finishing The Installation Of Geeklog


  • Please log in to reply
9 replies to this topic

#1 nick

nick

    Family Friend

  • Members
  • PipPip
  • 29 posts

Posted 27 September 2004 - 02:12 PM

Hey everyone. I hope you can help, because the people at Geeklog are not helping much at this point.
Let me preface by saying I downloaded GeekLog 1.3.9. it came in a tarball. I unzipped it and moved all of the files into my directory.
I want to have my blog on my subdomain http://blog.bordumb.com

So i uploaded all the files into the /blog/ folder. Including all of the files that were inside of the public_html folder so things could be a bit more secure and much easier to install.

I got through everything for the most part except when finalizing installation, I cam upon the success.php page which is supposed to guide me to the next step of installation. This turned up blank. I was also unable to get on any other page as they were also blank.

I looked in the error log and this turned up:
[27-Sep-2004 11:22:28] PHP Warning: mysql_connect(): Access denied for user: 'blog@localhost' (Using password: YES) in /home/bordumb/public_html/blog/system/databases/mysql.class.php on line 108

As of right now in my config file, these are my settings as I believe they SHOULD be set up.

$_DB_host = 'localhost'; // host name or IP address of your DB server
$_DB_name = 'bordumb_blog'; // name of your database,
// must exist before running the installer!
$_DB_user = 'bordumb_blog'; // MySQL user name
$_DB_pass = '*********'; // MySQL password


I had set up my database last night. The database being named 'blog' and the user for the database also names 'blog'. then of course my password.

In my lib-common.php file which I was supposed to modify, i followed the directions as follws.

* Configuration Include: You should ONLY have to modify this line.
* Leave the rest of this file intact!
*
* Make sure to include the name of the config file,
* i.e. the path should end in .../config.php
*/

require_once( '/home/bordumb/public_html/blog/config.php' );


Is that correct or incorrect?
I am assuming it is one of these two php files that is holding me back.

I hope someone can help me.
Nick P.
Milwaukee, WI

#2 MikeJ

MikeJ

    Big Gorilla

  • Members
  • PipPipPipPip
  • 2,369 posts

Posted 27 September 2004 - 02:58 PM

The first thing I would ask you to check is to make sure after you created the database, and the user, did you grant permissions for the user to the database?

If you go into "MySQL Databases" in your control panel, make sure that bordumb_blog is listed as "Users in bordumb". Otherwise, you need to scroll down to "Grant Permissions", select bordumb_blog user, bordump_blog database, select "ALL", and hit Grant Permissions button. Then you should be in good shape.
<a href="http://twitter.com/skraggy" target="_blank">Twitter</a> | <a href="http://plurk.com/skraggy" target="_blank">Plurk</a>

#3 nick

nick

    Family Friend

  • Members
  • PipPip
  • 29 posts

Posted 27 September 2004 - 03:36 PM

Yeah. I'm all set there
Still a no-go

Users in blog
bordumb_blog (Privileges: ALL PRIVILEGES)

This was also written to me by an admin on the geeklog forums.

A blank page is usually the result of an error somewhere else and the webserver being configured not to display error messages (the install script tries to switch error messages back on, but that may not work, depending on how the webserver is configured).

Check your error.log and try to retrace your steps. Als check the usual places (config.php and lib-common.php) for syntax errors (missing quotes or semicolons).


I have gone over the little stuff and can not seem to find an error(missing quotes or semicolons)

I also am unable to change the permissions of the error log file in the /admin/install directory to 777... it will not allow me to. I think that was created after I attempted to install though. So I dont think it is important in the install process.
Nick P.
Milwaukee, WI

#4 nick

nick

    Family Friend

  • Members
  • PipPip
  • 29 posts

Posted 27 September 2004 - 08:47 PM

Well, so far TCH MikeJ and I were doing a few things, but have yet to find a solution.
Anyone care to chime in? I would really like to get this up and running asap
Nick P.
Milwaukee, WI

#5 nick

nick

    Family Friend

  • Members
  • PipPip
  • 29 posts

Posted 27 September 2004 - 11:10 PM

okay... i am gonna lose it....

so far i have all of the files from the public_html folder that was supplied in the tarball in the blog directory.
I have set up another folder called configfolder in that directory and put the rest of the setup files in there.
I changed the config/php and the lib-common.php files for this

It is still not working....

There is SOMETHING I am missing here. Some small detail. Mike said he got it without a problem. He told me to do it this way and I fail.
What am i doing wrong
Nick P.
Milwaukee, WI

#6 TCH-Dick

TCH-Dick

    General Manager

  • Admins
  • PipPipPipPip
  • 5,786 posts

Posted 28 September 2004 - 12:13 AM

Here is what I have.

_Created directory blog and the directory configfolder within blog
_Uploaded all files from public_html to blog
_Uploaded all files outside of public_html to configfolder
_Set permissions to 775 on the following directories:
/blog/configfolder/logs
/blog/backend
/blog/images/articles
/blog/images/userphotos
_Created DB and User

_Edited config.php

// +---------------------------------------------------------------------------+
// | (1) Database Settings                                                     |
// +---------------------------------------------------------------------------+

$_DB_host         = 'localhost';   // host name or IP address of your DB server
$_DB_name       = 'cpanel-name_blog';     // name of your database,
                                   // must exist before running the installer!
$_DB_user        = 'cpanel-name';    // MySQL user name
$_DB_pass        = 'pass';    // MySQL password

// The table prefix is prepended to each table used be Geeklog to avoid name
// collisions with other tables that may already exist in your database.
$_DB_table_prefix = 'gl_';         // e.g. 'gl_'


// +---------------------------------------------------------------------------+
// | (2) Paths                                                                 |
// +---------------------------------------------------------------------------+

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '\' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['path']            = '/home/cpanel-name/public_html/blog/configfolder/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html']      = '/path/to/your/public_html/';
$_CONF['path_html']         = '/home/cpanel-name/public_html/blog/';


// +---------------------------------------------------------------------------+
// | (3) Site Settings                                                         |
// +---------------------------------------------------------------------------+

// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).
$_CONF['site_url']          = 'http://www.mysite.net/blog';

// Some hosting services have a preconfigured admin directory. In that case,
// you need to rename Geeklog's admin directory to something like "myadmin"
// and change the following URL as well. Leave as is until you experience any
// problems accessing Geeklog's admin menu.
$_CONF['site_admin_url']    = $_CONF['site_url'] . '/admin';

// This is the return address for all email sent by Geeklog:
$_CONF['site_mail']         = 'spam_me@example.com';

// Name and slogan of your site
$_CONF['site_name']         = 'MySite';
$_CONF['site_slogan']       = 'Stupid Slogan';

_Edited lib-common.php

require_once( '/home/cpanel-name/public_html/blog/configfolder/config.php' );

The install ran with no problems with this setup. I hope it helps.

Edited by TCH-Dick, 28 September 2004 - 04:04 PM.

Dick DeVance
General Manager
TotalChoice Hosting, Inc
dick@totalchoicehosting.com


Posted Image


#7 nick

nick

    Family Friend

  • Members
  • PipPip
  • 29 posts

Posted 28 September 2004 - 11:47 AM

thanks a lot for that info.
I am going to try it this afternoon.
I hope this works for me. :dance: :)
Nick P.
Milwaukee, WI

#8 nick

nick

    Family Friend

  • Members
  • PipPip
  • 29 posts

Posted 28 September 2004 - 01:29 PM

Well, I did everything as said above. Once I reached the success.php page, it was blank.
I started a brand new folder and a brand new database and user. all three called 'nick'. I made sure to take my time and get everything exact.

When you set the permissions to these...
_Set permissions to 775 on the following directories:
/nick/configfolder/logs
/nick/backend
/nick/images/articles
/nick/images/userphotos


Did you also then set the permissions to each individual file and folder inside of the folders as well?

Also, for the lib-common.php file, you have a colon after /home/
Should that be there? I removed it when I changed my lib-common file.

require_once( '/home/'cpanel-name/public_html/blog/configfolder/config.php' );


Do I need to delete a folder or file or something to continue? I did everything as explained above and still came up with a blank success page. ;)

Ther must be some reason why I am coming up with a blank page
Nick P.
Milwaukee, WI

#9 nick

nick

    Family Friend

  • Members
  • PipPip
  • 29 posts

Posted 28 September 2004 - 03:14 PM

Dirk - An admin from GeekLog

If the error message is still "PHP Warning: mysql_connect(): Access denied for user ..." as above, then the problem is with the database permissions, not with file permissions.

Make sure you've actually uploaded your changes and into the correct directory.

But, yes, you're supposed to change the permissions of the files in the logs and backend folders, too (the others only contain dummy files which can be ignored).


I cant find an error now and I did what Dirk told me to do.

I have done everything instructed for me to do. There is no error log this time so something must have been done right. I am just unable to see the site. Something is not right.
We must figure this out. Thumbs Up
Nick P.
Milwaukee, WI

#10 TCH-Dick

TCH-Dick

    General Manager

  • Admins
  • PipPipPipPip
  • 5,786 posts

Posted 28 September 2004 - 03:46 PM

Did you also then set the permissions to each individual file and folder inside of the folders as well?

Yes I set the permissions on all files in the directories.

Also, for the lib-common.php file, you have a colon after /home/

Sorry that was typo.


i'm not sure what the issue is. Check you PM and we will see what we can do.

Dick DeVance
General Manager
TotalChoice Hosting, Inc
dick@totalchoicehosting.com


Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users