Jump to content


Photo

Can't Connect Dreamweaver To Mysql


  • Please log in to reply
7 replies to this topic

#1 rksprst

rksprst

    Family Friend

  • Members
  • PipPip
  • 45 posts

Posted 14 July 2006 - 05:40 PM

When I try to add a mySQL connection I get an error.


I created the database and added the database user to it with ALL privilages. I also added % as an access host in cpanel mysql.

Here are images of what info I typed in. The FTP works well, it is the sql connection that doesnt.

EDIT: TCH-Bruce - I removed the images with your cpanel information in them - If you are going to post images like that at least blur out confidential information.

This is the error:
Posted Image
you can follow logic
or contest it all

#2 GroovyFish

GroovyFish

    Immediate Family

  • Members
  • PipPipPipPip
  • 691 posts

Posted 14 July 2006 - 06:09 PM

In the MySQL Connection setting:

Try changing the MySQL server to: localhost

#3 GroovyFish

GroovyFish

    Immediate Family

  • Members
  • PipPipPipPip
  • 691 posts

Posted 14 July 2006 - 06:13 PM

If you still get an error, try comparing all the information against what is in this post:

http://www.totalchoi...i...st&p=152297

#4 rksprst

rksprst

    Family Friend

  • Members
  • PipPip
  • 45 posts

Posted 14 July 2006 - 08:44 PM

EDIT: TCH-Bruce - I removed the images with your cpanel information in them - If you are going to post images like that at least blur out confidential information.

Thanks Bruce, figured without password it would be useless to have username info... guess maybe I was wrong(?).

So, here are the same images with the confidential info blurred out.
Posted Image
Posted Image

I read a bunch of threads on here regarding the same subject, but still I can't figure out how to fix it.
I haven't tried setting server to localhost, but since the mySQL is on the TCH server and not my computer, I don't see how that would help. I'll give it a shot though just in case. Any other suggestions though?

EDIT: So I read the thread you linked to... and it makes sense that localhost can work. Anyway I tried it... but to no avail. I get the same error.

Edited by rksprst, 14 July 2006 - 08:51 PM.

you can follow logic
or contest it all

#5 TCH-Bruce

TCH-Bruce

    Volunteer Moderator

  • Members
  • PipPipPipPip
  • 20,149 posts

Posted 15 July 2006 - 08:23 AM

Did you give your computer's IP address access to MySQL in cPanel? Enter your IP under Access Hosts or "%".

Bruce Richards
Forum Moderator
TotalChoice Hosting, Inc.
Webhosting by Total Choice Web Hosting - General Support Forum

I am a Forum Moderator. While I can assist in answering most of your hosting related questions, I am unable to answer questions about specifics relating to your account such as billing and server related issues. Should you need assistance in these areas, please contact our Help Desk or our many other options. Another good place to find answers is with our help pages, tutorials and movie tutorials.


#6 rksprst

rksprst

    Family Friend

  • Members
  • PipPip
  • 45 posts

Posted 16 July 2006 - 12:40 PM

Did you give your computer's IP address access to MySQL in cPanel? Enter your IP under Access Hosts or "%".

Yea, I also did that. Still get an error... very weird.
you can follow logic
or contest it all

#7 TCH-Dick

TCH-Dick

    General Manager

  • Admins
  • PipPipPipPip
  • 5,891 posts

Posted 16 July 2006 - 04:14 PM

Sorry, I must have have missed this thread but we are going to fix you up. You just need to make 4 small changes.
  • Under Testing Server change FTP host to just your domain without "ftp" e.g. totalchoicehosting.com
    I would suggest making this change under Remote Info as well
  • Under Testing Server change Host Directory to "public_html/"
  • Under MySQL Connection change MySQL Server to "localhost"
    Note: For the MySQL Server field you must enter localhost if PHP and MySQL are running on the same machine.
  • Go to http://www.whatismyip.org and add the IP listed to your Access Hosts. The IP you added is a local network IP and will not work
Good Luck :)

Dick DeVance
General Manager
TotalChoice Hosting, Inc
dick@totalchoicehosting.com


Posted Image


#8 sdanks

sdanks

    New To The Neighborhood

  • Members
  • Pip
  • 14 posts

Posted 20 January 2007 - 12:33 AM

Let me just say I have been trying to make this work for several hours ans was getting an error about could not find the file:
http://xxx.xxx.xxx.x...ts/MMHTTPDB.php.

I was trying to use my IP address because I do not have a website setup yet.

I finally had to use the following settings:

Say my cpanel username is dude123
MySql Settings:

Connection name: whatever
MySql Server: localhost
username: dude123_scott
password: **********
Database: dude123_voting

In the testing server setup:

Server Model: PhP MySql
Access: PHP
FTP Host: xxx.xxx.xxx.xxx (my tch ip address sent on signup)
Host directory: public_html/
Login: dude123
password: xxxxxxxx
URL Prefix: http://xxx.xxx.xxx.xxx/~dude123/

It was nut until I put the ~dude123 in the prefix that it started working.
This is probably not necessary if you have a domain name pointed at the site.
But I dont have one yet.

hope this helps.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users